x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.14.3 Bad performance with multiple windows open

When I have multiple (2-3+) editor windows open, e.g. static mesh editor window, mat instance editor window, the whole editor slows to a crawl, below 10 fps. This occurs even when the editors are tabbed and not currently being rendered.

With a single editor window open performance is ok.

This has started happening since 4.14.

DxDiag alt text

Product Version: UE 4.14
Tags:
capture.png (3.8 MB)
dxdiag.txt (27.9 kB)
more ▼

asked Jan 31 '17 at 11:33 AM in Bug Reports

avatar image

myertveho
1 1 2 2

avatar image AndrewHurley Jan 31 '17 at 05:04 PM

Hey myertveho,

It is kinda hard to tell from your screenshot, but are you working on a single monitor screen?

I tried testing this on my end, but getting the windows to dock on a single screen display like your screenshot is showing. Either way, I tested both single and double screens and attempted to get the editor's performance to slow down, but I was not seeing the drop in performance.

I might try testing on a weaker machine with less RAM to see if that reproduces the issue, but I will return once my testing has completed.

Thanks,

Andrew Hurley

avatar image Everynone Feb 07 '17 at 11:21 AM

This is how it looks like with multiple windows, the performance is cut in a very linear fashion

  1. windows: 60fps | 16.7ms

  2. windows: 30fps | 33.3ms

  3. windows: 20fps | 50.0ms

  4. windows: 15fps | 66.7ms

alt text

  • it does not seem to matter how many monitors are involved

  • it does not seem to matter which window is in focus

  • this also affects the PIE mode

  • the editor's 'Use Less CPU when in Background' setting does not affect this behaviour

tested on: 3570k @ 4GHz, 16GB, 7970 3GB, Win10 64b

untitled.png (682.2 kB)
avatar image Orkney Feb 14 '17 at 11:50 AM

I am also experiencing this exact issue

avatar image brothermechanic Apr 04 '17 at 09:52 AM

same for me windows/linux 4.15.1

Please fix it!

avatar image Inph1del Apr 04 '17 at 10:33 AM

Doesn't this happen because the visualization of the blueprints? That's been my assumption. All the nice orange wires lighting up to show you in real time what's firing off has got to take its toll.

avatar image brothermechanic Apr 04 '17 at 11:20 AM

It happened with all window types, not only BP I think problem is in UE interface toolkit, or in nvidia drivers, or windows/linux compositors.

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Hey guys,

Thanks for taking the time to elaborate and provide some extra information. We were able to reproduce this internally and have entered a bug report for the issue. You can track the issue by clicking the link below.

UE-41678

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

more ▼

answered Feb 07 '17 at 07:40 PM

avatar image keyle Feb 07 '17 at 11:22 PM

This has been happening forever, I can't believe there wasn't a ticket for it yet :-)

avatar image myertveho Feb 08 '17 at 08:40 AM

Thanks Andrew,

Sorry I didn't get back to you earlier, these emails were going to spam.

avatar image i.kurochkin Apr 12 '17 at 07:05 PM

Try link behind But dx12 make ue unstable

avatar image Chosker Dec 19 '17 at 11:35 AM

any update? this is simply unacceptable (using 4.18)

alt text

ue4performance.jpg (91.5 kB)
avatar image Zaggoth 6 days ago

I'd like to pile on and say that this is still a huge issue in 4.21.

(comments are locked)
10|2000 characters needed characters left

Hi, i encountered similar probs. Is this still an open issue?

more ▼

answered Aug 15 '17 at 08:48 PM

avatar image

ThomasVogel
1 1

(comments are locked)
10|2000 characters needed characters left

I have been working with 3 or 4 monitors for a very long time and just recently windows 10 updated (not sure if this was the cause or not) when this started happening. It drops below 10fps and unreal becomes unusable, the interface lags really badly.

If I type stat gpu in the editor it says Slate UI is taking anything between 20-200ms but as soon as I close all the extra windows and just have the main window it drops to 0.6ms.

I understand there is going to be some performance impact having more than one window open but it shouldn't be this huge and never used to be a problem.

I've tried everything to fix this (including -DX12) but nothing helps, did anyone here solve the issue? It's going to affect my productivity massively if I can't fix it :(

more ▼

answered Dec 12 '17 at 05:28 PM

avatar image

bishop86
65 9 14 18

(comments are locked)
10|2000 characters needed characters left

Just thought I'd come back and say I fixed this by uninstalling Geforce Experience. It seems the screen capture was causing it, it might also fix if you just disable that without uninstalling the whole thing.

more ▼

answered Feb 11 '19 at 06:02 PM

avatar image

bishop86
65 9 14 18

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question