x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Graph is linked to private object" Blueprint inherit LevelSequenceActor

I've been trying to make a blueprint that has LevelSequenceActor as parent. This works fine in the start. Then as you add scripting, in my case, some script to play/stop the sequence, some functions, some events, all working fine. Then at some point the blueprint seems to become corrupt in some way.

At this point it compiles fine and all. You can add the BP to the level. Save the level and all is good. But then you go into the BP again and do a little nothing, like moving a command, recompile and save. All fine. Back to the level. Save the level and this thing comes up.

 Can't save ../../../../../../blablabla/Content/tull.umap: Graph is linked to private object(s) in an external package.
 External Object(s): /Engine/Transient
 Try to find the chain of references to that object (may take some time)?

Answering yes or no to that question gives the same result:

 Warning Can't save ../../../../../../blablabla/Content/tull.umap: Graph is linked to external private object (unknown culprit) (unknown property ref)

Deleting the object in the level fixes it. And you can even add it again and save the level fine. Until you go into the BP again and do a change.

(I've been fiddling with this for a day now..)

So as a test I stripped the blueprint of all script, functions and events. Remove everything. Result: Still the same behavior. Note that I have no sequence ref/added as well. (it happens anyway)

So I'll send you the stripped down blueprint in a hope that you guys can use it in a empty level and get the same result as I.

link text

Product Version: UE 4.14
Tags:
more ▼

asked Feb 01 '17 at 10:19 AM in Bug Reports

avatar image

Arnleif
46 2 6 8

avatar image Rudy Q ♦♦ STAFF Feb 01 '17 at 06:48 PM

Hello Arnleif,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

avatar image Arnleif Feb 02 '17 at 08:53 AM

1: Yes I can. Using that attached resource.

2: Ok. Like I've already said but now in a list:

  • Make an empty project.

  • Unrar and copy the cutsceneplayer asset into the project.

  • Add it to the scene.

  • Save scene.

  • Open the cutsceneplayer blueprint.

  • Move the 'Construction script' box a little and compile+save the script.

  • Save the scene/level.

  • Observer the error.

3: No settings involved.

Enjoy.

avatar image Rudy Q ♦♦ STAFF Feb 02 '17 at 06:43 PM

I have run a few tests following the information provided. However, I have been unable to reproduce this issue on our end. Are there any small steps that may have been left out when running into this error? Could you double check to make sure that the issue can still be reproduced with the asset that was provided?

avatar image Arnleif Feb 03 '17 at 09:59 PM

Made a small video in case you missed something: http://take.ms/NftXk (And hopefully you can see it.)

It's a clean project. Launched via launcher. Unreal 4.14.3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After taking a look at the video I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use the link provided for future updates. Thank you for your time and information.

Link: https://issues.unrealengine.com/issue/UE-41667

Make it a great day

more ▼

answered Feb 07 '17 at 04:13 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 525

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question