x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

In-App Purchase Failed Read in 4.15 P2

Dear Unreal Engine,

In 4.14.3, I've noticed that IAP for iOS no longer needed to add code in DefaultEngine.ini, only have to change iOSEngine.ini in config folder of engine from DefaultPlatformService=MCP to DefaultPlatformService=IOS for iAP to work.

I opened the same project in 4.15 P2, changed the config but it doesn't work anymore, please advise and check.

  • Created simple third person project

  • Added UMG with button to Read-InApp Purchase Node to correct product ID

  • Changed the Config as above like what i did in 4.14.3

  • Launched to iOS

  • Not able to retrieve info of iAP.

  • Same project created in 4.14.3 works properly, once convert to 4.15 P2 project failed to read.

Product Version: UE 4.15 Preview
Tags:
more ▼

asked Feb 01 '17 at 02:14 PM in Bug Reports

avatar image

dizzynoob
106 5 11 14

avatar image dizzynoob Feb 01 '17 at 05:57 PM

I hope someone can help to solve this. Kinda urgent! thank you very much!!!

avatar image dizzynoob Feb 04 '17 at 11:15 AM

any updates on this matter?

avatar image dizzynoob Feb 05 '17 at 06:03 AM

Tested on iPhone 7 Plus and iPad Pro both not working as well.

avatar image dizzynoob Feb 08 '17 at 01:29 PM

Any advise and anyone tested iOS In App Purchase in 4.15 P2?

avatar image Samantha Sutton ♦♦ STAFF Feb 09 '17 at 06:52 PM

Dizzynoob,

I apologize for not getting to you sooner. Each update that you provide on your post puts you further and further down on my list for urgent tickets. I am currently looking into this issue and I will get back to you as soon as possible.

In the meantime, could you please upload screenshots of your set up? Is this happening when you test in Unreal Match, or are you using your own set up for blueprints? Also, have you checked Preview 4?

Thank you.

avatar image dizzynoob Feb 09 '17 at 11:10 PM

Dear Samantha,

I haven't tried 4.15 P4 but P3 is not working. I did in 4.14.3 and iAP works perfectly, once converted to 4.15 project it failed to read using the read in app purchase node . I've changed the iOSEngine.ini in 4.15 engine folder from DefaultPlatformService=MCP to IOS as well to get it work like 4.14.3, Game Center works perfectly, showuserloginui launched perfectly. Just unable to read the iap, I didn't tried Make In-App Purchase node as Read In app purchase node is not working. I hope can solve asap. Please asssit urgently. Thanks you!

avatar image dizzynoob Feb 09 '17 at 11:14 PM

My blueprint setup is as simple and as similar to the unreal engine documentation. As I mentioned, it works perfectly in 4.14.3, as in 4.14.3, I do not have to change or add in code lines to the defaultengine.ini as previous version. On 4.14.3 I just edited the iOSEngine.ini as like I said above, then it works. Once project open in 4.15, nothing happen in iAP. Thanks.

avatar image dizzynoob Feb 10 '17 at 01:27 AM

I've downloaded and tested in 4.15 P4 still same as well, ShowExternalLoginUI works okay, able to login game center, but unable to read or make in app purchase. It always go to Failed Pin in either Read or Make In-App Purchase.

avatar image Samantha Sutton ♦♦ STAFF Feb 10 '17 at 04:33 PM

IAP is working on our end. We would need to see your complete set up. So in order to better help resolve the issue, could you please upload your project to Dropbox or Google Drive and provide the link to me in a private message on the forums? It will not be shared publicly, only with Developers if necessary to resolve what's going on with your set up.

Thank you!

avatar image dizzynoob Feb 10 '17 at 05:29 PM

Hi, I've sent you a PM, Please check! I've sent 2 rar file for 4.14.3 version, and open a copy of same project in 4.15 P4 and change the iOSEngine.ini in 4.15 P4 Engine folder config. Please double check, the iOSEngine.ini is not in the rar since it's in the engine folder, i just changed the MCP --> IOS in OnlineSubsystem there. Thanks.

avatar image dizzynoob Feb 10 '17 at 05:31 PM

This is the iOSEngine.ini in 4.15 P4 Engine Config Folder.

Changed DefaultPlatformService=MCP ---> DefaultPlatformService=IOS

[/Script/Engine.GarbageCollectionSettings] gc.MaxObjectsInGame=131072

[Audio] AudioDeviceModuleName=IOSAudio ; Defines a platform-specific volume headroom (in dB) for audio to provide better platform consistency with respect to volume levels. PlatformHeadroomDB=0

[OnlineSubsystem] DefaultPlatformService=IOS

[Advertising] DefaultProviderName=IOSAdvertising

[DeviceProfileManager] DeviceProfileSelectionModule="IOSDeviceProfileSelector"

[/Script/IOSRuntimeSettings.IOSRuntimeSettings] bEnableGameCenterSupport=true

[OnlineSubsystemIOS.Store] bSupportsInAppPurchasing=true bUseStoreV2=true

[SlateRenderer] NumPreallocatedVertices=200

[LocalNotification] DefaultPlatformService=IOSLocalNotification

[/Script/Engine.GarbageCollectionSettings] gc.MaxObjectsInGame=131072

avatar image Samantha Sutton ♦♦ STAFF Feb 14 '17 at 03:38 PM

We are still actively working on this issue. Thank you for your patience.

avatar image dizzynoob Feb 14 '17 at 05:26 PM

Great. Thank you for your reply. Hope to hear from you soon!

avatar image Samantha Sutton ♦♦ STAFF Feb 20 '17 at 04:54 PM

We're still investigating this, hope to have more information soon. We believe there is a bug. I'll let you know once I know more. :) Thank you so much for your patience!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Dizzynoob,

UE-42184 has been entered for this issue. Currently this Jira is not being made public. If you'd like information on it in the future, please reply back referring to that issue and we can give you an update.

Thank you!

more ▼

answered Feb 20 '17 at 10:34 PM

avatar image dizzynoob Feb 27 '17 at 02:43 PM

Hi Samantha, is there any updates on this matter and is there any estimate when will it be fix? as iAP is kinda a core thing. Please advise. Thanks!

avatar image Samantha Sutton ♦♦ STAFF Mar 15 '17 at 09:23 PM

Dizzynoob,

In Engine\Config\IOS\iOSEngine.ini there's a Cvar: bUseStoreV2=true that needs to be set to false. If you fix that, you'll be able to ship your project.

This is the work around for now. :)

Thanks!

avatar image dizzynoob Mar 16 '17 at 09:23 AM

It works perfectly!!! Thank you! And if there's time maybe change the documentation as it seems outdated. Thanks again!!

avatar image Samantha Sutton ♦♦ STAFF Mar 16 '17 at 06:49 PM

We're working on our documentation, it just takes time. You're very welcome. :)

avatar image Tatev Jun 16 '17 at 06:15 AM

Just to summarize:

In Engine\Config\IOS\iOSEngine.ini I need to change

1) DefaultPlatformService=MCP to DefaultPlatformService=IOS

2) bUseStoreV2=true to bUseStoreV2=false

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Samantha,

Yes I would like update for this. Any estimation on this of when to fix as in-app purchase is kinda a core element in app developing.. hope you understand. Thanks a lot!

more ▼

answered Feb 21 '17 at 04:50 AM

avatar image

dizzynoob
106 5 11 14

avatar image Samantha Sutton ♦♦ STAFF Feb 28 '17 at 10:34 PM

This is on our to do list, it's not resolved yet. Feel free to respond within a few weeks for an update if needed.

Thanks!

avatar image TheWazz Jul 06 '17 at 03:33 AM

Is there any updates on the issue? I am experiencing this problem as well. I've going through forums and websites like crazy trying to correct this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey I have the same issue. I tried to change the IOSEngine.ini file but every time I package my game, the file sets itself back... How do I change the ini file consistent?

more ▼

answered Aug 28 '17 at 09:23 AM

avatar image

Tiefsignal
11 2 8

avatar image Tiefsignal Aug 28 '17 at 09:43 AM

For Mac Users: Lock the .ini file for overwriting. And Change it as documented above! Thanks Guys.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
more ▼

answered Jan 13 '19 at 07:02 PM

avatar image

SalihBalkan
429 16 30 58

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question