x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash when opening old level

So this is a very strange thing that just happen. I was working with a Unreal VR project, and decided to restart the engine to make the motion controllers work again. Seems to be a small issue where it doesn't see that the controllers are on. But yea I just restarted and then got crash. Changed the map name so I could start the project, but whenever I right click or try to open any of the levels I had made, it crashes. And the name of the maps are not the same as the name I give the .umap file, like it doesn't check if the map is there. So now all the work I put into the maps seems almost lost. The even strange thing is I got a slightly older version of the project, and those maps works fine. I tried to import those, and they crash too.

So I think its some kind of engine setting issue or something. If all comes up wrong, I can always try and move all the new things to the older project version. I can make a new map and it works fine.

Anyone seen this before or have any ideas?

Product Version: UE 4.14
Tags:
more ▼

asked Feb 01 '17 at 05:34 PM in Using UE4

avatar image

andrekek
36 2 5 7

avatar image Mikko S Animator Apr 05 '17 at 03:45 PM

So i have some what similar problem. And i wonder is there is a bug somewhere, because when i am in main menu level and i go to full screen, then i play the game.

Then i go pause menu and when i try to go to main menu, because it is main level, everything works, fine. In fact it does what i needed to do, that is open the main menu, but when you wait few second it all the sudden lags, and then it crashes.

Luckly this doesn't affect anything as most important things like save game is in game as a checkpoint and when you play, it loads where you left of...

avatar image andrekek Apr 05 '17 at 03:53 PM

Can be a similar problem to what I had then. Maybe you have something conflicting in that blueprint/widget. Something that tries to load and UE don't know what to do with it.

I have noticed from all the time I have spent in UE4, that any problem you have can be one of a million things that causes it. One way to help is to have one thing installed for the engine version you have. Its the thing that takes up like 10 GB. It helps with giving you a more detailed description of what happen just before the crash.

Other then that you just have to try and take out one thing at a time, trying to find what part exactly makes it crash. Duplicating the project or blueprint and take out one thing at a time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Well for anyone else having a similar problem all of the sudden, I found out what the problem was for me. I had put a child actor into the player pawn. And if it was in the level, it seemed to crash it. So I got into the blueprint in an empty level and deleted the child actor. That seemed to have fixed it. Might be something that will be fixed later, but it dose not seem to be a problem with normal blueprints or actors.

For a reference, that child actor blueprint I had in my blueprint, had another child actor in it. Might be that what caused it.

more ▼

answered Feb 01 '17 at 08:30 PM

avatar image

andrekek
36 2 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question