x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Package project cause crash when oculus is plugged in?

I've run into a problem with a project i'm working on.

The project works perfectly when run from the editor, even when run as a standalone project, but as soon as the project is packaged as a windows package, either 32bit or 64bit, the software crashes with a generic error message as soon as any level is loaded from the level select menu. It is worth noting that these crashes only occur when the oculus rift is plugged into the computer. As soon as the oculus is plugged out, the software is running fine and does not crash at all. this is a problem since the project is VR orientated.

I've packaged and run the software on two different machines. Both with the same failed result. I've tested it with the commercial release of oculus rift and the DK 1, and both delivered the same crashes on the package project, but works fine when run in the editor.

I then proceeded to delete all the functionality in the levels and even changed the default pawn back to the default firstpersoncharacter, esentially leaving empty levels to load from the menu, but as soon as the project is packaged and run with the oculus plugged in the crash still occur.

We were able, in the past, to package earlier test versions on UE 4.12 and they also ran without any crashes. But alot have been done and added since then so it's hard to say if it's the engine version or something else we added.

Any help is greatly appreciated. Thanks

Product Version: UE 4.14
Tags:
more ▼

asked Feb 02 '17 at 07:33 AM in Packaging & Deployment

avatar image

foxhound101
6 2 1

avatar image Rudy Q ♦♦ STAFF Feb 02 '17 at 04:05 PM

Hello foxhound101,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hello foxhound101,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

more ▼

answered Feb 06 '17 at 09:38 PM

avatar image

Rudy Q ♦♦ STAFF
48.5k 543 125 511

avatar image foxhound101 Mar 03 '17 at 12:19 PM

Hi Rudy, It seems this issue only happens when you manually deactivate/activate the oculus, and seems to happen in versions newer than version 4.12.

If you have trouble recreating the issue i will gladly send you a copy of my entire project via wetransfer or something similer. Please let me know if there is anythig i can provide from my side and where to send it to.

Thanks

avatar image Rudy Q ♦♦ STAFF Mar 07 '17 at 09:09 PM

If you would like to provide your project for me to take a closer look at you can do so with a link to a zipped down copy via google drive or drop box.

avatar image foxhound101 Apr 10 '17 at 08:59 AM

Thank you very much Rudy Triplett, I apreciate your trouble. Unfortunately the software has gone through so many changes since then that its basically a new piece of software at the moment and we havent run into the same error since we went back to 4.12 and stayed with it. I will let you know if we ever run into it again.

Regards Charl

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Rudy,

My apologies for not getting back to you, we reverted to 4.12 and the issue has stopped apearing. If and when i go to 4.14 again and find the same issues i will get back to you with more detail.

Thanks for your help and time spent on this issue, sorry for the inconvenience.

Charl " The Foxhound" Cronje

more ▼

answered Feb 24 '17 at 10:02 AM

avatar image

foxhound101
6 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Is it not VR in level select but becomes VR when changing level? at the moment there seems to be an issue in packaged projects when you switch VR on and off in game for some reason.

more ▼

answered Feb 24 '17 at 10:09 AM

avatar image

CactusFantastico
55 5 10 15

avatar image foxhound101 Feb 24 '17 at 11:45 AM

CactusFantastico, Yes thats exactly right, my main menu level(level select), works without VR, and then VR is turned on the moment a map is being loaded. Thanks for the reply, to re-iterate, the packaged project works fine in v4.12 so it seems to be an issue with turning on/off VR in game in v4.14 packaged projects.

avatar image CactusFantastico Feb 24 '17 at 03:01 PM

Yeah I had a feeling haha Same thing has been happening to me. Since 4.12 its been broken for some reason so the only solution I've found is to stay in 4.12 such as yourself or make it so it starts and stays in VR.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've run into a similar problem again in 4.16.

Packaged game works fine, but oculus causes fatal error when plugged in...

this is not good as my project is a vr one..

more ▼

answered Sep 18 '17 at 05:10 PM

avatar image

foxhound101
6 2 1

avatar image Rudy Q ♦♦ STAFF Oct 02 '17 at 03:05 PM

Hello foxhound101,

Are you able to reproduce this issue in a clean project? If so, could you provide a detailed list of steps needed to reproduce this issue on our end?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question