x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to stop Character movement when opening ingame menu?

Hey there unreal community, im busy building a 2 player online game. My problem right now is that when a player presses pause while he is also pressing forward, he will keep moving while he is in the in game menu.

Now this isnt really a big problem, just close the menu and you are good to go, however i also have a gameover screen that opens a ingame menu as well and it looks realy silly if you keep moving while game over. I use a "set input to ui only" node as soon as the menu opens but this doesnt stop any movement orders already in place.

Does anyone know how i can stop characters movement when the menu opens?

Product Version: UE 4.13
Tags:
more ▼

asked Feb 02 '17 at 02:36 PM in Blueprint Scripting

avatar image

grote pita
8 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

You mention Character - it has a component that has a half all movement node - I would do that in addition to the suggestions above to disabling inputalt text

untitled.png (77.7 kB)
more ▼

answered Feb 02 '17 at 05:40 PM

avatar image

BPANDREW
1k 22 27 125

avatar image grote pita Feb 02 '17 at 05:45 PM

Thanks, that fixed it

avatar image zincr0 Sep 18 '18 at 01:08 AM

Doesn't work on 4.20.2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Did you try doing this without using the Set Input to UI Only node?

What might be happening is, you're disabling the input from the gamepad the moment the UI is up, which therefore disables the "release" button or the change of axis values, whatever you're using, none of them are being registered or changed as you have disabled those updates, so the game assumes the inputs are just were you left them.

more ▼

answered Feb 02 '17 at 03:31 PM

avatar image

Willard720
323 17 25 56

avatar image grote pita Feb 02 '17 at 04:05 PM

if i remove set input to ui only, you are still able to issue movement and the camera will follow the mouse. again this wouldnt realy be a problem for the ingame menu but it would be silly if i could move while game over

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You can switch possession between the UI and the pawn; that way you can use your UI with a controller. https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/PossessPawns/Blueprints/

more ▼

answered Feb 02 '17 at 04:29 PM

avatar image

ErrinMiller
444 15 6 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question