Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Add custom component to Static Mesh and convert to bp breaks bp editor windows

When I add a custom created ActorComponent to a SM_Door I put into the level from the starter content and then convert the door in the view-port to a blueprint it causes the Blueprint editor windows not to be viewable.

  • Create a new c++ project (Empty Project)

  • Add code based on Actor Component (TestActorComponent)

  • From Modes tab, add SM_Door to the level

  • In SM_Door details panel, Add instance of TestActorComponent to the SM_Door

  • Blueprint->Convert Selected Actor to Blueprint Class

  • Try to open Blueprint to edit, can not see BP window.

Branch: 4.15

Commit Level: a5c5b9d322ecf1e4f44b0bc4b652e98f22fcd56d

It causes the window to open but its not visible, I don't know if its a bug where the windows extents are (0,0) - (0,0) or if its just not rendering. The only way to fix it is to delete the contents of Engine/Saved/ under UnrealEngine/. Then you can open up the blueprint editor window.

Product Version: UE 4.15 Preview
more ▼

asked Feb 02 '17 at 05:33 PM in Bug Reports

avatar image

158 6 10 22

avatar image Matthew J Feb 06 '17 at 04:54 PM

Hello Salamanderrake,

Thank you for reporting this. I'm not able to reproduce this behavior using the steps provided but it seems like it may have something to do with your display setup. Could you detail what your setup is like, such as how many monitors you're using and their resolutions? Are you using Windows 10's UI scaling feature at all?

Also, when you do this and the blueprint editor opens but is not visible, can you try hovering your cursor over the UE4 icon on the taskbar, moving to the mini-representation of the Blueprint Editor window, right-clicking and selecting Move? If you hit the arrow keys after this, it'll lock the window to your mouse so you can drag it on screen if it is happening to show up off screen somehow.

avatar image Salamanderrake Feb 09 '17 at 07:13 PM

First, adding a c++ component to the static mesh has no baring on this issue, its more easily reproduce-able with the SM_Door then other static meshes. Second I found the file that gets modified and what change breaks the BP editor window. it is


Here is a diff between a working config file and a broken one.

Excess information but the important lines, as far as I can tell, are WindowSize_X and WindowSize_Y, if they are both set to -10 they will not show up. Will try to investigate and see what is causing it to set the initial window size to -10,-10.

avatar image Salamanderrake Feb 09 '17 at 06:15 PM

This issue is on Linux, not Windows 10.I tried hovering over the task bar but on Linux other windows opened don't show up as secondary windows to UE4Editor. One monitor with 1920x1200 resoultion.

avatar image Doug E ♦♦ STAFF Mar 10 '17 at 09:15 PM

Hey Salamanderrake-

Sorry for the late reply. I have tested again and am still not able to get a crash when adding a component to a static mesh and convert it to a blueprint. Are you still seeing this happen in 4.15.0? If so, can you provide the full callstack from the crash as well as the exact setup code / reproduction steps or a small sample project that demonstrates the crash.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Salamanderrake-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Doug Wilson

more ▼

answered Mar 27 '17 at 12:54 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question