x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Getting a variable from a blueprint into a widget

The question is mostly in the title but to expand.

  1. Im trying to reference a variable inside BP_Inventory (Actor Blueprint) from within my WID_Inventory (Widget) I've created a variable within the widget (BPInventoryRef) but all the variables it calls return a value of zero. regardless of actual values.

  2. I have also tried using a cast to rather than a reference variable. but im unsure what i need to plug into the object wildcard on the cast node. Also, I've been told that this is a more resource hungry way of doing the same operation so i'm hesitant to use it.

I can't seem to find the correct nodes to make this work. any help would be appreciated.

This seems like something really simple but I've been stewing on it for quite a while now and thought I'd ask you lovely lot for a hand. This may be stating the blatantly obvious but im new to programming and UE4, so sorry for this potentially really dumb question. (it wouldnt be my first).

alt text

Product Version: UE 4.14
Tags:
error.jpg (992.7 kB)
more ▼

asked Feb 04 '17 at 04:21 PM in Blueprint Scripting

avatar image

Eightshot
143 7 15 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

managed to fix this with a little help from a friend so thought i would post the solution here for anyone else having the same issue.

This is how i got it working: alt text

asdasd.jpg (250.7 kB)
more ▼

answered Feb 08 '17 at 11:05 AM

avatar image

Eightshot
143 7 15 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question