x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Can't disable shadow casting on landscape

I have a tessellated landscape material, and turning off cast shadows on my directional light saves a lot of performance with almost no visual impact. I've searched around and it doesn't seem like there's any way to disable shadow casting on landscapes. Is this correct? I'd like to have tessellation on my landscape but not pay the extra cost for cast shadows on it that aren't even apparent due to the angle of the sun.

If it's not possible currently, I think this would make a very good feature.

Product Version: UE 4.14
Tags:
more ▼

asked Feb 05 '17 at 03:45 AM in Rendering

avatar image

Wilkes
96 6 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found a console command that accomplishes what I wanted:

r.AllowLandscapeShadows 0

In case anyone else is having this problem

more ▼

answered Feb 13 '17 at 05:25 AM

avatar image

Wilkes
96 6 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Self Shadowing cannot be disabled in UE4, whether it's landscape or Skeletal/Static meshes. This self shadowing is not paying the cost that dynamic shadow casting would be. However, tessellation on a landscape can become expensive really quickly.

https://issues.unrealengine.com/issue/UE-29134

more ▼

answered Feb 05 '17 at 04:55 AM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question