x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Access Violation in AssetDeleteModel.cpp when importing FBX file

Hi,

I'm on UE4.14.3 and I'm getting an access violation error when using the ImportAssets commandlet to import a simple FBX file. This is the command I'm running:

 UE4Editor-Cmd.exe $UE_PROJECTFILE -run=ImportAssets -AllowCommandletRendering -source=$FBX_FILEPATH -dest=Geometry/Meshes -importsettings=$SETTINGS_JSONFILE -replaceexisting

The content of the JSON settings file is:

 {
     "ImportGroups": [
         {
             "FactoryName": "/Script/UnrealEd.FbxFactory",
          "ImportSettings":
             {
             "bImportMesh": 1,
             "bImportMaterials": 1,
             "bImportTextures": 1,
             "bCombineMeshes": 0,
             "bConvertScene": 1,
             "bConvertSceneUnit": 1,
             "StaticMeshImportData":
             {
                "bAutoGenerateCollision": 0,
                "bRemoveDegenerates": 1
             },
             "SkeletalMeshImportData":
             {
             } ,    
             "AnimSequenceImportData":
             {
             }, 
             "TextureImportData":
             {
             }             
             }
         }
     ]
 }

The callstack for the access violation error is:

alt text

After looking at the source code for a while, I found that if I set the "bCreatePhysicsAsset" settings of the ImportAssets commandlet to false, the crash no longer occurs.

If I use UE4 Editor to manually import the FBX file, I get the following message in the log but the FBX is imported OK: "Warning The bone size is too small to create Physics Asset 'ButterflyValve_0_PhysicsAsset' from Skeletal Mesh 'ButterflyValve_0'. You will have to create physics asset manually."

Even if the issue is in the FBX file (i.e. bone size in the model), the ImportAssets commandlet should handle it gracefully and not crash like the UE Editor is doing.

Thanks, Softavi

Product Version: UE 4.14
Tags:
more ▼

asked Feb 06 '17 at 09:47 AM in Bug Reports

avatar image

Softavi
44 2 6

avatar image Matt.Williams Feb 14 '17 at 09:10 PM

Hey Softavi,

Any chance you can send me the fbx file that you're using? I'm having trouble reproducing this on my end. You can attach here or PM me a download link on the forums if you'd like to keep it private. Please respond here after you send it for tracking purposes.

-Matt W.

avatar image Softavi Feb 16 '17 at 08:35 AM

Hi Matt, it seems that I haven't got enough permissions to PM you.

avatar image Matt.Williams Feb 20 '17 at 09:11 PM

Hey Softavi,

We're giving you permissions to PM. You have to have some activity on the forums to be able to PM, but we can override that.

-Matt W.

avatar image Softavi Feb 21 '17 at 10:40 AM

Hi,

Thanks for sorting the permissions out. I've sent you a PM with a link to the FBX model.

I've tried with the latest version of UE4 (4.15) and I still get the crash with the same callstack.

Thanks

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Softavi,

Thanks for reporting this. I've entered UE-42334. You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

-Matt W.

more ▼

answered Feb 23 '17 at 09:30 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question