x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Intellisense stopped working

Hi all,

today my Intellisense stopped working in VS2015 on UE 4.13. I've written some problematic code and my project was crashing on startup. As my VS was still opened I commented it out and build the solution through VS. My projected started up but the Intellisense was not working. I closed and reopened VS but the Intellisense was still not working.

I tried closing VS and unreal, removed all the files in Binaries folder then used "Generated VS project files". After I launched my project again and opened a CPP class in the blue bar at the bottom of VS was showing:

  1. Scanning for additional files... (number of number)

  2. Parsing included files..

  3. Scanning #includes for additional files..

alt text but at the end Intellisense was still not working.

At some point of testing I added some code and got error in that blue bar - "Intellisense 'No members available'". Everything in the CPP file "is undefined" alt text

I tried re-logging into Microsoft account as Intellisense is not available for anonymous users.. But it didn't work.

I checked configurations related with VS in https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/index.html but nothing helped.

After that I updated VS2015 and restarted my computer but Intellisense is still not working.

Tried creating new project, downloading older UE version 4.11.1 and 4.12.5, setting #include "EngineMinimal.h" to "Engine.h" and I'm out of ideas. As I didn't manage to find solution in google I ended up looking for assistance in here.

Any help would be really appreciated! Thanks in advance!

Regards, Georgi R.

Product Version: UE 4.13
Tags:
loading01.png (128.9 kB)
loading02.png (145.8 kB)
more ▼

asked Feb 06 '17 at 10:01 PM in C++ Programming

avatar image

apokalypto
151 2 7 23

avatar image JamesSwann95 Feb 07 '17 at 02:54 PM

Intellisense is a bitch at the best of times. When in Visual Studio, the best way tor fix this, or at least from my experience is to simply close visual studios and re-open it. This usually fixes my issue

avatar image apokalypto Feb 07 '17 at 10:32 PM

Yep I tried that many times but with no luck.. I even tried building, exiting and re-entering https://answers.unrealengine.com/questions/17444/intellisense-doesnt-work-for-ue4-visual-studio-201.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I manage to fix my problem! This guy is a god: phoboz

I did this:

Build solution

Close VS

In the editor File->Refresh VS Project

File->Open VS

Give it 5-10 seconds to rescan files

Source: https://answers.unrealengine.com/questions/14354/intellisense-activation.html

more ▼

answered Feb 07 '17 at 10:42 PM

avatar image

apokalypto
151 2 7 23

avatar image JamesSwann95 Feb 08 '17 at 09:55 AM

That's good. But knowing intelliesense, this won't be the fisttimw that you'll have to do this

avatar image toberl Aug 22 '17 at 04:53 AM

Thanks, google led me here and this worked for me as well.

avatar image SoulTripper Mar 06 '18 at 05:51 AM

Worked for in VS2017. Google led me here as well. Thanks!

avatar image Desoxi May 12 '18 at 01:55 PM

Same here, worked for me in VS2017: intellisense had stopped working on one single cpp file. Now it works again. Thank you!

avatar image falxonPSN Jun 08 '18 at 03:56 PM

One more for the pile. Just got here and this fixed my problem with VS2017 and UE 4.19.2.

Also, by "give it 5-10 seconds," I think you meant 1-2 minutes. :)

avatar image deezero7 Nov 29 '18 at 11:51 AM

in the editor means ue4 engine

avatar image Olathuss Jun 15 '19 at 11:41 PM

This works great. Build solution is unnecessary unless there is a reason for it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In VS

go to Project>>"project_name" Properties>>NMake on the left sidebar>> put /Yu in the Additional Options under IntelliSense

more ▼

answered Nov 19 '17 at 09:33 AM

avatar image

AMULBHATIA
11 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey, for people who is having problems with IntelliSense, my problem might help some others. My IntelliSense was working on x86 but not x64

I tried everything to solve it but what had really happened was that I had overwritten the file "C:\Users\username\AppData\Local\Microsoft\MSBuild\v4.0\ Microsoft.Cpp.x64.user.props" with the content from a colleague to build other project.

I added these lines which are the ones which screwed up my x64 Intellisense...

<ItemDefinitionGroup> <ClCompile> <AdditionalIncludeDirectories> <\AdditionalIncludeDirectories> <\ClCompile> <\ItemDefinitionGroup>

So all I had to do was to REMOVE THEM

more ▼

answered Mar 14 '19 at 08:30 AM

avatar image

clau_ccanada
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question