x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Camera BP (Pawn) Can't Climb Slopes

I'm at a bit of a loss on this one.

My Camera is built inside a Pawn class BP. When I move the camera using the arrow keys, the camera root (pictured) will collide with Terrain, BSP, and Static Mesh, but it won't climb even the most gentle incline.

I've dug through the properties and class defaults, and I've enabled "Walkable Slope Override" with a Slope Angle of 90. Gravity has been toggled on and off with no apparent affect on anything. The collision option for "Can Character Step Up On" is enabled, although I'm pretty sure that isn't relevant. I don't know what I'm missing, and thus far my google-fu has failed to turn up any answers.

Any help here would be appreciated! alt text

Product Version: UE 4.14
Tags:
more ▼

asked Feb 06 '17 at 11:22 PM in Blueprint Scripting

avatar image

Poosh
13 5 6 10

avatar image Est_engine Feb 07 '17 at 01:01 PM

Hi man , i think you may have some problem with your collision post a screen of your pawn,

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

does your pawns camera use a spring arm? if so the collision sphere may need its size/collision settings tweaked - as suggested please post that as well

more ▼

answered Feb 07 '17 at 01:18 PM

avatar image

BPANDREW
1k 23 27 125

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Okay - I was looking over my camera movement controls and I noticed I had the "Sweep" checkbox ticked off. Unticking this kind of half fixed the problem... the camera doesn't get stuck on terrain slopes now, and instead just passes right through the terrain.

I tried playing around with the collision settings to see if it was something simple I had overlooked, but none of the settings I tried had any effect. (Tried presets for Pawn and Custom, object types for World Dynamic and Pawn, and setting individual collision responses manually, but I may have just not tried the right combination)

Attached below is the current collision and physics set up for the Camera Root. Attached to the camera root is a Spring Arm and Camera (in that order). And as I said - after unticking the box for Sweep, the camera root now completely ignores collision on the terrain. The terrain's collision is set to the Block All preset with an Object Type of World Static (All collision responses are set to Block)

alt text

cameraroot.png (93.3 kB)
more ▼

answered Feb 07 '17 at 03:38 PM

avatar image

Poosh
13 5 6 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question