x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Emitter with zero rate in Cascade unable to be turned on via BP parameter?

I have a particle system containing 3 emitters that have their Spawn rates controlled by parameters in blueprints using "DPM Direct".

On each emitter in Spawn > Rate I have the "Constant" value set to 0 so that I can turn them on in the blueprint using "Set Float Parameter".

However setting spawn rate Constant at 0 seems to result in me not ever being able to turn the system on at all.

If I set any of the Spawn rate constants in the particle system in Cascade to a non-zero like "0.5" the TurnOn function works and all the emitters are at the right rates - (expect of course that one emitter being on at the start)

If I run a "TurnOff" function after that to set the rates back to 0 and then run TurnOn i can successfully turn them off and on at will.

So i figured a workaround was to put a non zero spawn rate in Cascade and then run TurnOff at BeginPlay. That does indeed turn the particles off. But TurnOn then has no effect just like before.

So I'm wondering if there is some sort of performance or culling thing that essentially deactivates the system because no emitters are active at runtime? Or maybe there is a another way I should be doing this? Or maybe this is a bug?

The significance of the emitters is "critical" I turned off "can be baked" in case that had something to do with it. None of those seemed to have any effect.

Product Version: UE 4.14
Tags:
more ▼

asked Feb 07 '17 at 08:44 PM in Blueprint Scripting

avatar image

gelliott
278 7 8 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So in case anyone sees this the solution turned out to be not using Parameters but calling Activate/Deactivate on the Particle Actor in blueprint.

more ▼

answered Apr 06 '17 at 08:37 PM

avatar image

gelliott
278 7 8 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question