x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Problem - Build Failed Unknown Error

I'm from an architectural background, starting to dip my toes into using UE4 for VR architectural visualisations. I've followed several hours of tutorial on line and built a small scene which can be explored in VR, using the Virtual Reality Blueprint as a template. It works fine when I play in VR Preview mode but have come across a problem trying to package. Unfortunately I have no coding knowledge, so the attached error log means nothing to me and I'm looking for guidance as to how to resolve the error. link text

I'm using Unreal Engine 4.14.3 on a PC running Windows 10 Pro 64-bit.

I tried packaging using a clean project using the Virtual Reality Blueprint template and this works fine.

Any assistant would be most welcome.

Product Version: UE 4.14
Tags:
more ▼

asked Feb 08 '17 at 05:05 PM in Packaging & Deployment

avatar image

ronmilne
1 2 3 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello ronmilne,

Usually the quickest way to find out what may be causing your project to fail when packaging is to use the Find function (ctrl+f) in a text editor program to search the log file for the word "Error" and "Warning". From doing that with this log, this error came up:

ERROR: Windows SDK v8.1 must be installed in order to build this target.

Can you please install the Windows SDK v8.1 from Microsoft's website, restart your computer, and then try again? If you receive any more errors, please let me know and we can try to figure it out.

more ▼

answered Feb 08 '17 at 08:07 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 91 417

avatar image ronmilne Feb 09 '17 at 10:20 AM

Hi Matthew,

thank you for your reply.

I've installed SDK v8.1, restarted the PC and then tried again but unfortunately it's still failing.

I've attached then new output log. link text

Kind regards

avatar image Matthew J ♦♦ STAFF Feb 09 '17 at 02:15 PM

It looks like it was replaced by another error that is the result of another missing component.

No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

This means that your Visual Studio 2015 installation is missing a certain component. Please open your Control Panel > Programs and Features > Microsoft Visual Studio 2015 > Change > Modify and then select "Common Tools for Visual C++ 2015" under "Visual C++" and then continue with the installation. This should resolve that error. If you receive another error, please try searching for the error message as these are common errors that should be easy to find the solution for.

avatar image ronmilne Feb 09 '17 at 05:11 PM

Thank you Matthew, that worked perfectly and packaged with no problems.

Thank you once again for your help.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question