x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Local multiplayer JoinSession not working. TravelFailure: LoadMapFailure.

I am trying to connect to my hosted multiplayer game in my LAN. Actually, for two days now. What I get is the following log:

 [2017.02.09-14.22.44:881][432]LogLoad: Took 0.023728 seconds to LoadMap(/Game/Maps/UEDPIE_0_MainMenu)
 [2017.02.09-14.22.44:881][432]LogNet:Warning: Travel Failure: [LoadMapFailure]: Failed to load package '/Game/Maps/UEDPIE_0_LobbyScene'
 [2017.02.09-14.22.44:881][432]LogNet:Warning: TravelFailure: LoadMapFailure, Reason for Failure: 'Failed to load package '/Game/Maps/UEDPIE_0_LobbyScene''. Shutting down PIE.
 [2017.02.09-14.22.44:881][432]PIE:Warning: Warning TravelFailure: LoadMapFailure, Reason for Failure: 'Failed to load package '/Game/Maps/UEDPIE_0_LobbyScene''. Shutting down PIE.
 [2017.02.09-14.22.44:882][432]LogBlueprintUserMessages: Early EndPlayMap Detection: Level '/Game/Maps/MainMenu.MainMenu:PersistentLevel' has LevelScriptBlueprint '/Game/Maps/MainMenu.MainMenu:PersistentLevel.MainMenu' with GeneratedClass '/Game/Maps/MainMenu.MainMenu_C' with ClassGeneratedBy '/Game/Maps/MainMenu.MainMenu:PersistentLevel.MainMenu'
 [2017.02.09-14.22.44:923][432]LogOnline:Display: NULL: FOnlineSubsystemNull::Shutdown()
 [2017.02.09-14.22.44:932][432]LogPlayLevel:Display: Shutting down PIE online subsystems

Now, the LobbyScene is present and works great when I host the game with that computer. The other computer that hosts the game actually IS on that LobbyScene, and it has the exact same installation folder as the client computer, freshly copied over.

I also tried the same with a packaged game, a standalone game and every other possible way I could think of. It just does not work for me.

I also tried the same using Steam, no go. With a second Steam account on another computer of course.

And as you can see in the pictures I actually use a plugin now in the hope that AdvancedSessions solves my problems. But it also did not help. Before that I was using the standard to create sessions, same results.

I am on the same network, only a switch between the computers. I completely disabled all firewalls on the computers by now.

Maybe the error is in here? DefaultEngine.ini

 [/Script/Engine.GameEngine]
 +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")
 
 [OnlineSubsystem]
 DefaultPlatformService=Steam
 bHasVoiceEnabled=true
 
 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480
 
 [Voice]
 bEnabled=true
 
 [Core.Log]
 LogOnline=all
 LogOnlineGame=all
 
 [/Script/OnlineSubsystemSteam.SteamNetDriver]
 NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"

or maybe in here? Build.cs

 public class Helden : ModuleRules
 {
     public Helden(TargetInfo Target)
     {
         PublicDependencyModuleNames.AddRange(new string[] { "Core",
                                                             "CoreUObject",
                                                             "Engine",
                                                             "InputCore",
                                                             "Sockets",
                                                             "Networking",
                                                             "VRExpansionPlugin",
                                                             "AdvancedSessions",
                                                             "OnlineSubsystem",
                                                             "OnlineSubsystemUtils" });
 
         PrivateDependencyModuleNames.AddRange(new string[] {  });
 
         DynamicallyLoadedModuleNames.Add("OnlineSubsystemSteam");
 
         UEBuildConfiguration.bForceEnableExceptions = true;
     }
 }

So yeah. Please ask further questions. I have no idea why it is happening, logging does not show anything, I can't really put breakpoints into that code either.

alt text

alt text

alt text

alt text

Product Version: UE 4.14
Tags:
more ▼

asked Feb 09 '17 at 02:50 PM in Blueprint Scripting

avatar image

skyflash
8 2 3 6

avatar image luisbento Jun 07 '17 at 06:26 PM

If you want to load a map you shouldn't put "open level" block. You should put a console command saying "servertravel /Game/Maps/ExampleMap01". Make sure it has a space between servertravel and the slash.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question