x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Windows 10 packaging for iOS Fails UE 4.14

When trying to deploy to an iPad from windows I get the errors: Error Provision not found. A provision is required for deploying your app to the device.
Error Signing key not found. The app could not be digitally signed, because the signing key is not configured.

I've tried 4.12, 4.13 as well and I have also tried from a mac, same stuff. I've made sure all my certificate, provisioning profiles are valid, have a specific provisioning profile for the app ID and have created a fresh project. I'm attaching the output log as an image.alt text

Product Version: UE 4.14
Tags:
capture.png (9.3 kB)
capture2.jpg (242.4 kB)
capture3.jpg (59.1 kB)
more ▼

asked Feb 09 '17 at 05:46 PM in Packaging & Deployment

avatar image

Zaeran24
151 15 18 24

avatar image Matthew J ♦♦ STAFF Feb 09 '17 at 07:08 PM

Hello Zaeran24,

What are your packaging settings like? Are you trying to Launch On with "For Distribution" enabled? If so, this could be the problem. Also, could you provide your full log file? What happens if you just try to package instead of launching on?

avatar image Zaeran24 Feb 10 '17 at 09:22 AM

It's the same whether I launch, package for shipping or development. I'll send you the log files. I don't have for distribution enabled.

avatar image Matthew J ♦♦ STAFF Feb 10 '17 at 02:56 PM

From looking at the log, it seems like it recognizes that you have your certs and provisions but the problem is that they don't match. As for the signing key issue, have you done all of the steps in this quickstart, specifically this one?

avatar image Zaeran24 Feb 10 '17 at 03:47 PM

The certificate definitely matches the provisioning profile, I'll send you a couple of screen shots to show.

avatar image Matthew J ♦♦ STAFF Feb 14 '17 at 09:34 PM

Since you never expressly said, did you try everything listed in that quickstart tutorial? Also, have you tried using the Developer cert instead of the Distro one if you're not packaging for Distribution? Could you also show the rest of the settings under iOS and also under Packaging?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

We haven't heard from you in a while, Zaeran24. Are you still experiencing this issue? If so, could you provide the information I requested in my most recent comment? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Feb 22 '17 at 05:17 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 92 417

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question