x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Generating dll while UE4 editor is opened.

I noticed, that in 4.15 I cannot build c++ code while editor is opened. I had not such problem with 4.14. If I close the editor, it goes thru just fine.

Here is the error:

 2>     Creating library C:\GameArtists\Unreal\GameSavePro\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-GameSavePro-1478.lib and object C:\GameArtists\Unreal\GameSavePro\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-GameSavePro-1478.exp
 2>     Creating library C:\GameArtists\Unreal\GameSavePro\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-GameSavePro-1478.suppressed.lib and object C:\GameArtists\Unreal\GameSavePro\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-GameSavePro-1478.suppressed.exp
 2>ERROR : UBT error : Failed to produce item: C:\GameArtists\Unreal\GameSavePro\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-GameSavePro-4536.lib
 2>  Total build time: 3.89 seconds (Local executor: 0.00 seconds)
 2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3075: The command ""C:\Program Files (x86)\Epic Games\4.15\Engine\Build\BatchFiles\Build.bat" GameSaveProEditor Win64 Development "C:\GameArtists\Unreal\GameSavePro\GameSavePro.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.
 ========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Product Version: UE 4.15 Preview
Tags:
more ▼

asked Feb 10 '17 at 03:34 PM in Bug Reports

Flash7 gravatar image

Flash7
106 3 4 10

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Feb 15 '17 at 10:41 PM

Hi Flash7,

I just tried to recreate this issue in a new 4.15 project, and didn't have any trouble doing a hot reload. Would you be able to provide some additional information?

  • Are you using the binary version of the Engine installed through the Launcher, or did you build the Engine from source code?

  • What version of Visual Studio are you using?

  • What changes to your code are you making?

  • How are you starting the build process?

Tim

Flash7 gravatar image Flash7 Feb 15 '17 at 11:01 PM

Are you using the binary version of the Engine installed through the Launcher, or did you build the Engine from source code?

I run the Editor via Launcher

What version of Visual Studio are you using?

VS 2015 (update 3)

What changes to your code are you making?

I have a blueprint library. Every time I change a source code (.h and .cpp) and recompile, I have this problem.

How are you starting the build process?

In Visual Studio - build solution (F7) If I close the editor, build goes thru just fine and I see in output: 2> Deleting old hot reload file: "C:\GameArtists\Unreal\GameSavePro\Binaries\Win64\UE4Editor-GameSavePro-7218.dll". 2> Deleting old hot reload file: "C:\GameArtists\Unreal\GameSavePro\Binaries\Win64\UE4Editor-GameSavePro-7218.pdb".
Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Feb 16 '17 at 05:02 PM

Do you get the same result if you right-click on the project in Visual Studio's Solution Explorer and select the Build option?

Tim

nrobinson gravatar image nrobinson Feb 16 '17 at 05:15 PM

Wierdly the first time I did a right click on the project build I got hundreds of duplicate function linker errors, but since then I'm getting the same behaviour as using F7/Ctrl+Shift+B

Flash7 gravatar image Flash7 Feb 16 '17 at 05:38 PM

Tim, yes, there is the same error if I select Build from solution explorer.

nrobinson gravatar image nrobinson Feb 16 '17 at 05:56 PM

Hi Tim,

I'm not at all certain, but I think it may be related to building plugins. We have a code plugin in the game directory rather than installed into the engine. The VS built hot-reload dll for the game has a dependency on a hot-reload dll for the plugin, however the plugin hot-reload dll hasn't been output by the build process, although a lib and exp have. When building through the editor the game hot-reload dll has a dependency on the base plugin dll instead.

i.e. VS: game-437-win.dll -> plugin-437-win.dll (missing) Editor: game-437-win.dll -> plugin-win.dll

Cheers,

Nick

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Feb 17 '17 at 04:15 PM

Thank you for the clarification everyone. Using a project that contained a plugin, I was able to see the error message that was described. I am curious to know if the hot reload is actually failing for you, though. In my case, Visual Studio was reporting the build failed with that error message, but in the Editor the changes were available (only changes to project code, plugins currently do not get hot reloaded).

Tim

Flash7 gravatar image Flash7 Feb 17 '17 at 04:58 PM

Tim, I tried to replicate it on different c++ projects (no plug-ins), and I see that the same error on each of them if an editor is opened. Just for clarification, it worked well in 4.12-4.14. This type of error showed up only in 4.15

nrobinson gravatar image nrobinson Feb 17 '17 at 05:09 PM

Unfortunately that's not the case for me, the code changes (in the primary game dll) aren't going through to the editor.

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Feb 17 '17 at 09:13 PM

That's unfortunate, I thought I had managed to reproduce what you were seeing. I will have to look into this further next week. Would it be at all possible to get a sample project that I could compare with my setup to see where I am doing things differently?

Tim

nrobinson gravatar image nrobinson Feb 16 '17 at 04:33 PM

We're having similar issues, hot-reload is working correctly if we use the compile button in the editor, however building through visual studio successfully creates a DLL but the editor the fails to load it, which disables hot-reloading causing later hot-reload builds to fail to link in VS and the compile button to disappear. This is consistent across our team so it's not specific to one machine although we all probably have a similar setup.

Win10, VS2015 Update3

VS and editor output below:

[3/4] Link UE4Editor-MyGame-27-Win64-DebugGame.dll 2> [4/4] Link UE4Editor-MyGame-27-Win64-DebugGame.lib 2> Creating library E:\dev\MyGame\Game\Intermediate\Build\Win64\UE4Editor\DebugGame\UE4Editor-MyGame-27-Win64-DebugGame.lib and object E:\dev\MyGame\Game\Intermediate\Build\Win64\UE4Editor\DebugGame\UE4Editor-MyGame-27-Win64-DebugGame.exp 2> Creating library E:\dev\MyGame\Game\Intermediate\Build\Win64\UE4Editor\DebugGame\UE4Editor-MyGame-27-Win64-DebugGame.suppressed.lib and object E:\dev\MyGame\Game\Intermediate\Build\Win64\UE4Editor\DebugGame\UE4Editor-MyGame-27-Win64-DebugGame.suppressed.exp 2> Deploying MyGameEditor Win64 DebugGame... 2> Total build time: 14.43 seconds (Local executor: 5.37 seconds)

LogHotReload: New module detected: UE4Editor-MyGame-27-Win64-DebugGame.dll LogHotReload: Starting Hot-Reload from IDE LogSlate: Took 0.000244 seconds to synchronously load lazily loaded font '../../../Engine/Content/Slate/Fonts/Roboto-Light.ttf' (159K) LogModuleManager:Warning: ModuleManager: Unable to load module 'E:/dev/MyGame/Game/Binaries/Win64/UE4Editor-MyGame-27-Win64-DebugGame.dll' because the file couldn't be loaded by the OS. Warning: HotReload failed, reload failed /Script/MyGame. LogContentBrowser: Native class hierarchy populated in 0.0141 seconds. Added 2327 classes and 487 folders. Display: HotReload took 0.1s.

j_zeitler gravatar image j_zeitler Mar 02 '17 at 01:45 PM

I'm also having this problem now. Started with OPs problem (hot reloading *.dll works but *.lib does not) but now the editor doesn't seem to load the *.ddl either:

 LogModuleManager:Warning: ModuleManager: Unable to load module 'C:/z/myproj/Binaries/Win64/UE4Editor-myproj-4414.dll' because the file couldn't be loaded by the OS.
 Warning: HotReload failed, reload failed /Script/myproj.

Edit: Creating a new 4.15 project still does not have this more "critical" version of the problem.

Akihiro.Kayama gravatar image Akihiro.Kayama Feb 15 '17 at 11:56 PM

I experienced same problem with EGL 4.15.0 Preview 4/Visual Studio 2015 Update2/some modification added ThirdPerson project. DLL was successfully produced without error log but UBT reported fail. After deleting Intermediate/ directory, the symptom had gone away and I can't reproduce it.

Akihiro.Kayama gravatar image Akihiro.Kayama Feb 18 '17 at 02:52 AM

Here is a reproducible step I found with EGL 4.15.0.

  • Launch EGL 4.15.0 from EGL

  • Create a new C++ ThirdPerson project (named tps16)

  • edit and save tps16.cpp (no actual modification needed)

  • Build with VS2015 (and hot reload DLL is generated successfully)

  • Finish UE4Editor.exe (with its window close button)

  • execute UE4Editor.exe(with double click on tps16.uproject)

  • edit and save tps16.cpp (no actual modification needed)

  • Build with VS2015(Ctrl+Shift+B)

  • and then DLL is generated successfully but UBT reports failed

 2>Build:
 2>         Compiling game modules for hot reload
 2>         [1/3] Compile tps16.cpp
 2>         tps16.cpp
 2>         [2/3] Link UE4Editor-tps16-8715.dll
 2>         [3/3] Link UE4Editor-tps16-6471.lib
 2>            ????????? C:\proj2\ue415sample\tps16\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-tps16-8715.lib ??????????? C:\proj2\ue415sample\tps16\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-tps16-8715.exp ?????
 2>            ????????? C:\proj2\ue415sample\tps16\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-tps16-8715.suppressed.lib ???????????? C:\proj2\ue415sample\tps16\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-tps16-8715.suppressed.exp ??????
 2>         -------- End Detailed Actions Stats -----------------------------------------------------------
 2>     1>
 2>ERROR : UBT error : Failed to produce item: C:\proj2\ue415sample\tps16\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-tps16-6471.lib

Don't care "???" which is because UBT can't handle Japanese character. These lines means success. I noticed .lib are numbered wrongly in log. Actual generated .lib is UE4Editor-tps16-8715.lib.

I think this is related to https://issues.unrealengine.com/issue/UE-42041 (hot reload DLL is wrongly loaded when editor launched, without rebuild)

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Feb 20 '17 at 10:53 PM

Hi Akihiro.Kayama,

Thank you for this repro case. I was able to use it to easily reproduce the issue without needing to use a plugin. I want to check a couple more things tomorrow, including upgrading projects to 4.15, but I think this is the issue that most people are seeing.

Tim

mpxc gravatar image mpxc Feb 20 '17 at 04:35 AM

I've also been getting the same error whenever doing runtime compiling from Visual Studio after upgrading from 4.14.3 to 4.15.0. Doing any modification to a .cpp or .h file and building while the editor is open causes the error, but if the editor is closed there is no problem.

I'm not using any editor plugins and haven't made any changes to the project or tried any new features since upgrading to 4.15.0.

 1>------ Build started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
 2>------ Build started: Project: Project, Configuration: Development_Editor x64 ------
 2>  Compiling game modules for hot reload
 2>  Performing 3 actions (4 in parallel)
 2>  ProjectComponent.cpp
 2>  [2/3] Link UE4Editor-Project-8362.dll
 2>  [3/3] Link UE4Editor-Project-3008.lib
 2>     Creating library D:\UnrealProjects\Project\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Project-8362.lib and object D:\UnrealProjects\Project\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Project-8362.exp
 2>     Creating library D:\UnrealProjects\Project\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Project-8362.suppressed.lib and object D:\UnrealProjects\Project\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Project-8362.suppressed.exp
 2>ERROR : UBT error : Failed to produce item: D:\UnrealProjects\Project\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Project-3008.lib
 2>  Total build time: 14.57 seconds (Local executor: 0.00 seconds)
 2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3075: The command ""C:\Program Files\Epic Games\UE_4.15\Engine\Build\BatchFiles\Build.bat" ProjectEditor Win64 Development "D:\UnrealProjects\Project\Project.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.
 ========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

mpxc gravatar image mpxc Feb 20 '17 at 06:55 AM

Weirdly enough, the hot reload seems to be succeeding and reflecting the changes despite the error...

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello everyone,

Thank you for the information that you have provided for this issue. I was able to reproduce the issue that I believe the majority of you are seeing, and reported it in UE-42205 for further investigation. If you are seeing different results from what I reported in that ticket, please continue to provide any additional information you may have specific to your results and I will keep trying to reproduce those results.

Tim

more ▼

answered Feb 21 '17 at 04:06 PM

Tim Lincoln gravatar image

Tim Lincoln ♦♦ STAFF
15.6k 410 41 242

eudrea gravatar image eudrea Feb 23 '17 at 12:58 PM

The workaround suggested doesn't always work (for example in our case, it doesn't work once). That's the error we're getting. I've reproduced the steps you specify in the Bug description on how to workaround it. "ERROR : UBT error : Failed to produce item: D:\Lucru\Cube\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Cube-7736.lib"

One strange thing which I don't think I've seen before is the linking to 2 different file names (the lib is not the same as the dll).

 > 1>  Compiling game modules for hot
 > reload 1>  Performing 4 actions (4 in
 > parallel) 1>  EnemySpawner.cpp 1> 
 > TankStage3BossComponent.cpp 1>  [3/4]
 > Link UE4Editor-Cube-7449.dll 1>  [4/4]
 > Link UE4Editor-Cube-7736.lib


bstone gravatar image bstone Feb 28 '17 at 06:59 AM

Yes, UBT in 4.15 loses track of the build numbers and for some reason it expects the wrong build number for the .lib file while in fact they match that of the .dll.

Xetatronics gravatar image Xetatronics Feb 26 '17 at 07:01 PM

I have exacly the same problem since I updated to 4.15. It worked just fine in 4.14. Deleting the Intermediate folder and generating project files worked until i started the editor, closed it and opened it again afterwards. Now again, i can't build my project...

orieporter gravatar image orieporter Feb 26 '17 at 07:12 PM

I have the same error. Also if I build in the editor I get no errors but blueprints are not reflecting changes made in code. This is for a project that was upgraded from 4.14 to 4.15.

Dustums gravatar image Dustums Mar 01 '17 at 05:20 PM

I tried the work around in UE-42205 and it worked for a single compile but then failed on the second try

 2>  Compiling game modules for hot reload
 2>  Performing 4 actions (4 in parallel)
 2>  [2/4] Link UE4Editor-RuntimeMeshComponent-2318.lib
 2>     Creating library E:\Projects\Unreal\Pegs 4.15\Plugins\UE4RuntimeMeshComponent-2.0\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-RuntimeMeshComponent-2318.lib and object E:\Projects\Unreal\Pegs 4.15\Plugins\UE4RuntimeMeshComponent-2.0\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-RuntimeMeshComponent-2318.exp
 2>  PegsPlayerCharacter.cpp
 2>  [3/4] Link UE4Editor-Pegs-9255.dll
 2>  [4/4] Link UE4Editor-Pegs-6902.lib
 2>     Creating library E:\Projects\Unreal\Pegs 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Pegs-9255.lib and object E:\Projects\Unreal\Pegs 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Pegs-9255.exp
 2>     Creating library E:\Projects\Unreal\Pegs 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Pegs-9255.suppressed.lib and object E:\Projects\Unreal\Pegs 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Pegs-9255.suppressed.exp
 2>ERROR : UBT error : Failed to produce item: E:\Projects\Unreal\Pegs 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Pegs-6902.lib

I am using a plug in RuntimeMeshComponent. I checked and my code changes aren't making it into the editor, so it is not just a reporting issue. The hot load did indeed fail. If I close the editor I can build just fine.

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Mar 02 '17 at 06:57 PM

The issue here appears to be triggered by any hot reload performed on a project. The first hot reload seems to work fine, but any hot reloads that are performed after that (the Editor does not actually need to be closed in between hot reloads, I found) will display this result. We have some engineers looking into this, and will hopefully have it resolved soon.

Tim

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Mar 06 '17 at 11:00 PM

Hello everyone,

I just wanted to provide a quick update on this issue. We have a fix in place for this issue, and it is expected to be included in the first hotfix for 4.15. If you continue to see this occurring in 4.15.1, please let us know.

Tim

nrobinson gravatar image nrobinson Mar 22 '17 at 10:24 AM

Hi Tim,

We're still seeing the same issue in 4.15.1, no change to repro steps or result.

I don't believe this is the same as you're seeing in UE-42205. As previously mentioned the editor is not reporting a successful hot reload but that the OS can't load the produced dll.

Nick

Xetatronics gravatar image Xetatronics Mar 11 '17 at 12:25 AM

Thanks a lot guys! Once the Hotfix is out i will try that out and come back to you in case the problem still exists!

Dustums gravatar image Dustums Mar 21 '17 at 04:57 PM

Build 4.15.1 made my compile error go away, but the hot reload does not take effect. I have to close the editor and reopen it to see my code changes in editor. This is a soul-crushing hit to my workflow iterations.

I believe this is related to me using a plugin (namely UE4RuntimeMeshComponent-2.0), though hot reload worked fine in 4.14.

Kanibel gravatar image Kanibel Mar 24 '17 at 03:41 AM

Just like some of the comments above, 4.15.1 fixed the visual studio error, but we are still getting the hot reload failed in editor.

Using VS17 on Windows 10 and only have one plugin in the projects folder (FMOD Audio)

wjakobczyk gravatar image wjakobczyk Mar 24 '17 at 09:41 AM

I'm having the same issue - hot reload failed in editor.

In addition, when I just restart the editor then on startup I get "The game module 'X' could not be loaded. There may be an operating system error or the module may not be properly set up. Another build in VS resolves that and the editor starts. Fails on next hot reload of course.

I tried removing Intermediate and regenerating VS project files - did not help.

The project is using a plugin and references it in the C++ code. I can't move the code in, as it's a 3rd party plugin. Hope the issue will be resolved soon as it has huge impact on productivity...

wjakobczyk gravatar image wjakobczyk Mar 24 '17 at 10:19 AM

Until it's fixed, is there a way to disable hot reloading on new build in VS but still be able to hot reload when built in Editor? Then I could build in VS to fix compilation errors and do additional build in Editor when ready for testing. Now a VS build forces restart of Editor.

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Apr 03 '17 at 09:36 PM

Hi everyone,

Could you please clarify where you are still seeing this fail for you? I ran some tests in both 4.14.3 (using Visual Studio 2015) and 4.15.1 (using Visual Studio 2017), and in both versions I got the same results. When I made changes to both the project code as well as the plugin code, the project code would get hot reloaded successfully and the changes would be seen in the Editor, but the changes to the plugin code would not be seen in the Editor. Both results were expected, since plugins don't hot reload.

If anyone has a sample project that shows the trouble you are having, and specific instructions with regards to what changes you are making and how you are starting the compile process, that would be very helpful since it appears to be working fine when I test it.

Tim

wjakobczyk gravatar image wjakobczyk Apr 04 '17 at 06:54 AM

Hi Tim, The issue is still there, with "Unable to load module" when trying to do hot reload. I don't have any sample project as I'm using a 3rd party plugin and I'm not familiar with making plugins myself. Hopefully someone else can provide a sample...

Flash7 gravatar image Flash7 Apr 06 '17 at 10:30 PM

After an update, I started getting these errors (see screenshot) after a hot reload (4.15.1):

And in output log I see a lot of:

LogLinker:Error: BPGC_ARCH_FOR_CDO_GameSaveProLibrary_5 has an inappropriate outermost, it was probably saved with a deprecated outer (file: ../../../../../../HELM/depot/TheSoulkeeperVR/Content/Blueprints/GameFlow/GameFlowBase.uasset)

What helps - close editor, recompile, open editor, recompile assets with errors to remove bad references.

alt text

Flash7 gravatar image Flash7 Apr 07 '17 at 12:12 AM

Also this one:

LogLinker:Error: HOTRELOADED_GameSaveProComponent_0 has an inappropriate outermost, it was probably saved with a deprecated outer (file: ../../../../../../HELM/depot/TheSoulkeeperVR/Content/Blueprints/GameFlow/GameFlowDoorBase.uasset)

Krzysiek_TATE gravatar image Krzysiek_TATE Apr 13 '17 at 02:47 PM

We've got problem with compiling outside the editor with FMOD and UE 4.15/4.15.1 too. It didn't happened before. Very annoying and time consuming for programmers. Please fix that ASAP because it's not.

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF Apr 13 '17 at 04:23 PM

I still have not been able to reproduce any of the ongoing issues that are being reported in 4.15.1. In my tests, hot reloading in 4.15.1 results in the same behavior that I see in 4.14.3. Any additional information that may help reproduce the results that you are seeing would be very helpful.

Tim

wjakobczyk gravatar image wjakobczyk Apr 14 '17 at 11:47 AM

In my case hot reload stopped working when I added the GameSparks plugin to my project and added use of their API in my C++ game code. It worked fine in 4.15 until I added and referred to the plugin. I never used the plugin prior to UE 4.15 so not sure if it's a regression in this version.

Krzysiek_TATE gravatar image Krzysiek_TATE Apr 14 '17 at 12:03 PM

Exactly same here. I'll send you example project on Tuesday. I've reproduced that.

Krzysiek_TATE gravatar image Krzysiek_TATE Apr 18 '17 at 07:53 AM

I wasn't able to upload it here, cause it's too big ( 20mb ), so I put it on mega.nz https://mega.nz/#!odZxRDST!GjPPGVl79_daR2A5q7aewrMjvXv_R8XpsEb1M_fzSK4

What I did was: 1. Opening 4.14 project in 4.15 ( just to be sure ). 2. Added fmod 3. Added custom actor class 4. Included some fmod header file 5. Called some random fmod static function. 6. Hot reload doesnt work after that.

Krzysiek_TATE gravatar image Krzysiek_TATE 2 days ago

Somebody is/will be working on that? When should we expect any news?

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF yesterday

Hi Krzysiek_TATE,

Thank you for the sample project that you provided. That got me started in the right direction, and I believe I am now able to reliably create a test project that shows the issue that you are still having. I have some additional tests that I want to run on this in the morning, but it looks like this may have already been corrected in our latest internal version of the Engine. I want to see if I can track down when this was corrected.

Tim

Tim Lincoln gravatar image Tim Lincoln ♦♦ STAFF 20 hours ago

Hello everyone,

I was unable to determine exactly what change resolved the issue internally, but I was able to confirm that it appears to be working again. The test case that I was able to create with Krzysiek_TATE's help worked fine in 4.14.3, then failed to hot reload successfully in 4.15.1. It still seems to be failing the same way in 4.16, but it is working again in the Master branch.

If any of you that have been seeing this ongoing hot reload issue occur have built the Engine from source code and don't mind building the Engine from the Master branch, could you check and see if your hot reload issues are resolved there as well? I am hoping that the test case I was able to put together will cover any outstanding hot reload issues, but I can't confirm that without your help.

Tim

(comments are locked)
10|2000 characters needed characters left

I think I have some similar issue going on with my project. I started working with the spine plugin for ue4 (skeletal 2D animsation plugin) and it worked perfectly fine until I tired to package my project yesterday. I had some errors showing up that required me to update my plugin because they were using editor-only classes in the first version.

However, after updating the plugin UE4 required me to perform a rebuild for two .dll involved in the plugin. The automatic rebuild failed and asked me to perform a manual rebuild from source. When using the rebuild solution tool from VS2015 pro it comes up with an error such as "failed to produce item : "Project"/.../"Plugin.lib".

I lack any programming skill so my project is full blueprint and to be honest I don't understand like half the stuff that is going on in this thread. Yet it would be awesome is a solution could be released for this plugin packaging issue.

Best regards, Thom

more ▼

answered Apr 19 '17 at 09:40 AM

Khannarc gravatar image

Khannarc
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question