x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Sequencer Keyframe lerp Bugg

Found this issue in a project im working on and was able to reproduce it in a clean project, link below.

If you have a level sequencer with camera cuts etc with multiple keyframes, the lerp for the camera between the keyframes changes if you move the last keyframe. As you can see in the video, i have 4 keyframes where the camera moves between them, at first they move perfectly as intended, if i move a keyframe in between (not the last one), they still move as intended. But if i move the last one, the lerp to the Second to last keyframes is different, it moves, then freezes for a little bit, then continues to the last keyframe. This happens, even if you move the last keyframe, then move it back to where it was.

Video showing the bugg: https://www.youtube.com/watch?v=KkHsdJDGFls&feature=youtu.be

Clean project with the bugg: https://drive.google.com/file/d/0B-hVYtzySBWTSEZsc1dUMV9Ea28/view?usp=sharing

PS. dont you get any karma for reporting bugs? This stuff takes some time xD

Product Version: UE 4.14
Tags:
more ▼

asked Feb 12 '17 at 06:43 AM in Bug Reports

avatar image

nameLive
18 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi nameLive,

In your project, the 4th key is set to have broken tangents (see the curve editor). I am assuming that you copy/pasted the first key, which breaks tangents on the keys around it so as to not mess up their interpolation with the other keys.

Broken tangents will cause those harsh transforms those harsh transforms. You can simply select your 4th key(s) and set Cubic (Auto) interpolation again.

-Matt W.

more ▼

answered Feb 17 '17 at 09:00 PM

avatar image nameLive Feb 18 '17 at 01:14 AM

Hi, i did not copy paste the first key but by pressing Cubic on the last key it fixed the interpolation and made it smooth again, this is going to save me some headache. :)

Thanks!

avatar image Matt.Williams Feb 21 '17 at 07:11 PM

Glad to hear it. Whenever something weird like this happens, turn to the curve editor to see what's going on there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question