x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Need to reimport to get custom collision to work

This seem to be an bug, when I have a FBX with both LODs and Collision meshes, when I import the file into UE4, it only seem to import the basemesh and the LODs, but won't import the collision meshes until I rightclick it in the content browser and choose reimport. Sure I can just reimport after importing, but that's not really a proper solution.

I'm using 3DS Max 2016 and UE4 v4.13.3. The basemesh, LODs and UCX are all in a group, UCX attached to the basemesh, and selected the group, basemesh and LODs and applied Level of Detail set to it, and then exported it.

As an separate issue, if you have Transform Vertex to Absolute disabled, the collision is not in the same location as the basemesh.

Product Version: UE 4.14
Tags:
more ▼

asked Feb 12 '17 at 04:20 PM in Bug Reports

avatar image

McGreed
11 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey McGreed,

I was able to import a mesh with LODs and Custom Collision without any issues. My workflow was a little different though.

After I set up the LODs for the meshes I then modeled out the custom collision Geometry and gave it the UCX naming convention. I didn't add it to a group or attach it. If you would like you can send me your FBX or MAX file to test with to see if I can reproduce the issue on my side. You can PM me here: https://forums.unrealengine.com/member.php?484739-Ed-Burgess

Also here is the FBX I tested with.

Regarding the other issue you mentioned would you mind making a separate AnswerHub post for it as others who are having that issue will find is easier that way.

Thanks,

Ed

more ▼

answered Feb 15 '17 at 08:40 PM

avatar image McGreed Feb 15 '17 at 10:57 PM

Heya,

Thanks for replying. I have tried to import your model, and it does seem to import the collision right away with no problem with the same settings I use to import my model. I included a screenshot of the import window setting. Sending you a PM with link to a FBX file I have the issue with.

avatar image Ed Burgess ♦♦ STAFF Feb 16 '17 at 03:50 PM

Did your workflow of parenting collision meshes to LOD0 ever work for you in previous versions?

I was able to get the model to import correctly after removing the collision meshes from the LOD group.

I would recommend keeping the Collision Meshes as separate and not made to be children of any of the LOD meshes. There is no real advantage that comes from parenting your collision geometry to your base mesh.

Other than keeping things neat and organized in Max that is. ;)

avatar image McGreed Feb 16 '17 at 06:38 PM

The main reason for doing this is that I made a script for exporting, which will mass export all the models that is in my selected groups, and export them individually, with collision and LODs. Since 3DS Max crashes if you have the collisions in the group alongside the basemesh and LODs, this is the only way I can export them all together, without having to do some scene searches for collisions.

avatar image Ed Burgess ♦♦ STAFF Feb 20 '17 at 03:27 PM

Just updating you, a bug report has been filed here: https://issues.unrealengine.com/issue/UE-42141

Feel free to track the issue as it is reviewed by our dev staff. Keep in mind this issue may not be addressed quickly or prioritized.

Thanks,

Ed

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question