x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Morph target animation not importing correctly

Worked fine in earlier versions. When importing animation with blendshape data, seems to only pull the first set of blendshapes it finds. This is an issue as we have characters in multiple meshes and multiple blendshapes. We verified the fbx is exporting correctly, so this seems to be an engine import issue.

Product Version: UE 4.14
Tags:
more ▼

asked Feb 13 '17 at 10:01 PM in Bug Reports

avatar image

Spectral Ink
224 10 15 23

avatar image Matt.Williams Feb 20 '17 at 05:44 PM

Hey SpectralInk,

I'm having trouble reproducing this with an asset that I created. Could you send me the .mb and fbx files? You can attach them here or PM me a download link on the forums if you'd like to keep it private.

-Matt W.

avatar image Matt.Williams Mar 29 '17 at 09:35 PM

Hey Spectral Ink,

I'm so sorry this got lost in the mix. I recently got another PM and saw your messages there. I haven't been able to reproduce this in 4.15 with your assets. Can you confirm that it is still occurring in 4.15 for you?

-Matt W.

avatar image Spectral Ink Mar 30 '17 at 12:23 AM

definitely still broken in 4.15. Have not tried it in 4.15.1 yet.

Taken an asset that already existed and trying to re-import it. Not only will it not update the blendshapes or remove the old ones, its also not updating material id's

avatar image Spectral Ink Mar 30 '17 at 12:37 AM

actually, looks like I'm getting a bad export on my end on my current test character, so I'll get back to you

avatar image Spectral Ink Mar 30 '17 at 12:54 AM

ok, got my character exported correctly. looks like blendshapes do not import in initial import, but if you re-import the come in.tried it in 4.15 and 4.15.1. When the character exists they come in fine, otherwise I have to import then immediately re-import

avatar image Spectral Ink Mar 30 '17 at 07:00 PM

BTW, found another issue. A re-import doesnt clear out old blendshapes.

Create a character with blendshape A. Import it into the engine. Then delete blendshape A and create blendshape B. re-import, you now have both A and B

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

The morphs not importing is a known issue that is fixed for 4.16 (see UE-43058).

After you reimport, does everything look ok?

I believe your second issue will probably be resolved by UE-21650, which is not public visible, but it covers reimport issues with morphs.

-Matt W.

more ▼

answered Mar 30 '17 at 08:28 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question