x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Epic Flying Demo Camera Lag Option Causes Jitter/Stutter

Epic Flying Demo Camera Lag Option Causes Jitter/Stutter on the ship when you play in editor. I set this in blueprint in the spring arm settings that the camera is attached to.

Is there a work around for this? I really like the effect that it produces (minus the shaking of course).

I'm guessing that this is a bug?

Product Version: Not Selected
Tags:
more ▼

asked Jun 14 '14 at 06:16 AM in Bug Reports

avatar image

NickZucc
203 14 19 148

avatar image TJ V ♦♦ STAFF Jun 14 '14 at 02:45 PM

Hi NickZucc,

I attempt to reproduce what you're seeing but I haven't been able to get your results.

I enabled my SpringArm camera lag and rotation lag. I set the Lag Speed to 45 and the Rotation Lag Speed to 30.

Could you list your setting or post a screenshot of them?

avatar image NickZucc Jun 14 '14 at 06:20 PM

Thanks for trying. I made a brand new project using the flying blueprint. I then enabled the lag options on the spring and that was all I had to do to cause the problem. The problem is the ship mesh jitters. ...everything camera wise is good. Would you like a video to see the problem?

avatar image TJ V ♦♦ STAFF Jun 14 '14 at 09:22 PM

Sure, if you could that would be great.

avatar image NickZucc Jun 15 '14 at 01:35 AM

TJ, I went to make a video after some changes I was making in a map of mine and UE4 crashed on me. When I restarted the problem was no longer present. I have added a custom mesh to a map of mine that I am working on and every now and then there is a very slight (the problem before was rather extreme) jitter and it very rarely happens...not sure if it is really even worth making a video at this point.

Thanks for your help on this, I hope this doesn't show up again...I'm still wishing this slight jitter of the mesh wasn't happening but it is at least passable for right now. If worse comes to worse would you be able to advise on how to recreate this type of set up in blueprint or point me to some resources to do so? Thanks!

avatar image NickZucc Jun 17 '14 at 04:05 AM

I found a new piece to this jitter problem, it is showing up really bad when I use the play in "stand alone game" option. I made a video of this with the problem on the map that I have made changes to and I also checked this in the default start up flying project and it had the same issues. Can anyone check this on their end? Thanks!

Vimeo Video Of The Problem

https://vimeo.com/98400359

(How do you embed video on this site?)

avatar image Isaac Nichols Jun 17 '14 at 04:55 AM

I have this problem too. I was trying to narrow down what is causing it. I think it is vsync related or too many vsync's enabled. For some reason when I enabled vsync in the console command it wouldn't go away but in the ini file as a stand alone game then it was very smooth. Not sure if this happens only for flying objects because I didn't notice it with humanoid characters walking.

avatar image TJ V ♦♦ STAFF Jun 17 '14 at 01:47 PM

I reproduced what looks to be the exact effect you are seeing by playing while the level was still building in the background. You said above that it stopped happening after you restarted after the crash.

Could you make sure that your level is completely built and retest it once it is finished?

avatar image NickZucc Jun 17 '14 at 03:42 PM

TJ,

I completely built my level (built all) and then saved my level and I am still getting the same behavior. Works fine in PIE but not in Stand Alone. Thanks again for your continual help on this.

avatar image TJ V ♦♦ STAFF Jun 18 '14 at 02:24 PM

Could you post a screenshot of the entire Details panel for the SpringArm and your Components panel? I looped in another developer, this seems to be a new issue.

avatar image NickZucc Jun 19 '14 at 02:25 AM

Sorry for the delay. Here are the settings that I have.

alt text

avatar image TJ V ♦♦ STAFF Jun 19 '14 at 08:00 PM

I still can't get your results. But since this is happening in the template project as well, could you post your dxdiag?

To find it, just go to the Start Menu and type dxdiag into the search bar. If you are on a Mac just post your hardware specs.

avatar image NickZucc Jun 19 '14 at 08:22 PM

Thanks again for looking into this!

Here is the saved off DxDiag

avatar image TJ V ♦♦ STAFF Jun 19 '14 at 09:29 PM

It's not a problem, you're very welcome.

It could have something to do with running UE4 on a laptop. Not saying laptops aren't supported, just sometimes we see some performance hitches with them.

Check to see if you are running some sort of energy saving software like Nvidia Optimus. Optimus will move the processing to your on-board video card when it determines that you aren't using enough to run your Nvidia graphics card. We have had users in the past say that this is what has caused lagging and glitching issues for them.

avatar image NickZucc Jun 20 '14 at 01:25 PM

TJ, I went into the bios and double checked to make sure that the Nvidia Optimus was disabled. There was some settings for the Intel processor to conserve power at times, so I disabled that as well.

But unfortunately the mesh stutter is still happening in game. (My fear is that when I go to cook my final game this is the performance that will be happening.)

The other thing to note is that I am a faculty member for a University and in our program we have gone the laptop route (fairly powerful laptops) so the students can work at school, home, bus....you name it. I would love to get more powerful workstations but it just isn't in the cards for our program.

If we have to go the laptop route, is there a configuration that Epic would recommend moving forward? Thanks again,

avatar image TJ V ♦♦ STAFF Jun 20 '14 at 06:21 PM

At the moment nothing official, but we understand that many of our users are running UE4 on laptops. So our developers are looking into this and hopefully we will have something to telling everyone soon'ish.

avatar image JackNorris Jul 28 '14 at 11:52 PM

Could we have someone look into this issue again please? This is definitely not a laptop graphics adapter issue as I am running an AMD Radeon R290X and I am getting the same issue.

Additionally here is another user reporting the same issue -> https://answers.unrealengine.com/questions/62723/camera-spring-arm-jitters.html

It happens with the UFO demo and with a custom built project using our own vehicles both in the editor and with fully cooked builds. The jittering happens as soon as you enable camera lag.

Here is what I have found so far... The issue is worst for me when camera lag is turned on and I have something else running that is utilising the video card (like a HD video in VLC, an active YouTube video etc). As soon as I close these applications the issue is dramatically reduced but not eliminated. For reference I find it easier to see using a camera and rotation lag speed of 50.

Whilst I appreciate that running things in the background is going to affect the performance I can quite happily do these things with other engines and games without issue. I can also do it with Unreal Engine as long as I don't use the spring arm ;)

Please can you continue to investigate this issue?

avatar image TJ V ♦♦ STAFF Jul 29 '14 at 02:12 PM

Hi Jack,

I should be able to test this further very soon. We've noticed that this issue is happening on some laptops or PC's running Radeon cards. I am going to be changing my Nvidia out for a Radeon card and will testing this again.

avatar image TJ V ♦♦ STAFF Aug 01 '14 at 10:07 PM

I just installed the exact same Radeon card and couldn't reproduce the issue in-house. Could you also post your dxdiag? Here is a link on how to find that info if you need it.

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

avatar image JackNorris Aug 03 '14 at 12:06 AM

Thanks for testing, here is the dxdiag as requested.

Interestingly my friend has a nearly identical system (R290 non X) and cannot replicate the issue either.

dxdiag.txt (77.4 kB)
avatar image TJ V ♦♦ STAFF Aug 04 '14 at 01:56 PM

I see that a slightly newer version of your graphics card driver is out (version 14.4). Could you install it and retest? Make sure you don't download the Beta driver, because they are generally unstable.

avatar image NickZucc Jul 30 '14 at 02:30 PM

Just to note, I have a dell laptop with an Nvidia K 5100.

avatar image NickZucc Aug 30 '14 at 10:49 PM

Just wanted to make sure that this is still on someone's radar at Epic. This is a showstopper when working with the Oculus. It's bad enough on the PC but really bad on the Oculus.

avatar image bigzer Sep 01 '14 at 10:56 AM

What UE version are you using?

avatar image bigzer Sep 01 '14 at 10:56 AM

We are facing the same issue with a Nvidia GTX 790 and same with Nvidia GTX 570. We are running UE4.2.1. Our scene is quite heavy so just to make sure I'm running PIE with r.screenpercentage to 50 to make 100% sure I had enough horsepower and the problem still occurs (less often though). I tried to limit the FPS to 60 and still also have issue. I think the problem occurs when the framerate fluctuates. I'm going to compare the FPS with maybe the position of the camera and try to confirm that they are directly linked. I will come back and post the results soon link text

avatar image TJ V ♦♦ STAFF Oct 30 '14 at 03:05 PM

Hi HateDread,

This is still being looked into by our developers but it has moved up in priority. For future reference here is the number for the issue in our tracking software: JIRA #3685.

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

After some investigation I think its related to the way EPIC calculates the position of the spring/camera. The method's math is based on your framerate and works well if it is stable (which is a bad assumption as framerate always drops somewhere even for a fraction of a second). If the frame rate fluctuates too much the positioning of the camera can be incorrect for a frame or two hence the stuttering. If you set a histogram based on the framerate you will notice that there is a direct correlation to 'strong' fps fluctuation and this stuttering effect although I noticed sometimes only a ~3fps fluctuation is enough to cause the problem.

In other words the stutter you see is not directly because of framerate fluctuation which mostly goes unoticed by our brain but its because the math to position the camera assumes a certain framerate to know where to place the camera and sometimes that assumption is wrong, it has nothing to do with your graphic card or drivers and everyone is affected by it if the conditions framedrop+enough speed to notice it are met.

It would be great if Epic could change the way they handle the update rate, I also love the effect!

more ▼

answered Sep 01 '14 at 01:40 PM

avatar image

bigzer
620 40 59 80

avatar image savagebeasty Sep 02 '14 at 12:06 PM

glad someone got to the bottom of this problem I gave up months ago :)

I think you are correct though as my PC specs are pretty cack in the grand scheme (gtx 470 and quad core Q6660).

I just made my own camera system in the end anyway as the spring arm with the lag enabled isn't very good for 360 rotations, horrible gimbal locking going on. Need quarternions rather than euler rotation.

avatar image HateDread Oct 30 '14 at 02:59 AM

Bumping this - has any progress been made as to a solution? Gets pretty bad at times.

avatar image Ryan Darcey Dec 21 '14 at 08:49 PM

Nice that someone is on this! I've got the same problem. Look forward to a fix going through!

Also, where do we find the JIRA database to check progress on the fix?

avatar image TJ V ♦♦ STAFF Dec 26 '14 at 02:58 PM

Hi rcdarcey,

Currently our JIRA database isn't public, but this may change at some point going forward. As for it's status, I've messaged the developer that is working on this issue and I hope to post an update here after the holidays.

Cheers,

TJ

avatar image bigzer Dec 26 '14 at 03:36 PM

Great to hear that, the effect is fantastic on our vehicles if you overlook the stuttering issue of course.

avatar image TJ V ♦♦ STAFF Mar 06 '15 at 11:35 PM

Hey everyone,

I'm sorry it's been a while on this issue. The investigation of several non-critical bugs had to be delayed while we prepped for GDC and this was one of them. We plan to investigate this issue soon and will post back here with updates.

Cheers,

TJ

avatar image bigzer Mar 07 '15 at 01:23 AM

I haven't had the occasion to test it out yet but I think there was some kind of improvement done in 4.7 no?

Here's what I saw: New: Added substepping to camera Spring Arm Component to address variance at different frame rates.

Is this a temp solution or is this for something else?

avatar image TJ V ♦♦ STAFF Mar 07 '15 at 05:30 PM

You're right, there was some improvements made in this area in 4.7. We retested this after that fix went in and we were able to reproduce some 'jittering' in certain scenarios, so we reopened the issue to investigating it a bit further.

avatar image lpalbou Oct 09 '16 at 03:53 PM

Hi TJ Ballard,

Any update on this issue yet ?

I am on 4.12.5 and the jittering when camera lag is activated is still there.. I confirm that it is somehow related to frame rate and it happends both on desktop & laptop.

avatar image Ryan Darcey Oct 15 '16 at 06:36 PM

kryann, expand the advanced properties in the "Lag" section of your spring arm component by clicking the small down arrow at the bottom of the section in the editor. there are settings in there to help remove the jitter caused by variable framerate.

https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/UsingCameras/SpringArmComponents/

avatar image SoulSharer Oct 15 '16 at 02:50 PM

Even when you do not use spring arm, it jitters for some reason. I tried to APlayerController::SetViewTarget to watch other's player pawn (in a multiplayer with dedicated server and listen server) walking around, it jitters with or without blending turned on. (Also no camera lag enabled on pawn's cameras)

And yeah, I'm using 4.13.1, problem still persists I'm afraid, trying to get to the root of it myself.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I also have this problem when using the spring-arm for a vehicle. I replaced the interpolation code with some custom smoothing code of my own which is proven in previous projects and I also checked the algorithm using a spreadsheet model with different frame rates - which it passed.

However, I'm still seeing jittering of the camera connected to the spring-arm, albeit much reduced from the jittering produced by the standard spring-arm interpolation code.

I can only assume that the car itself is jittering about and doesn't have the smooth, linear velocity across frames that the numbers would have us believe. Is the actual rendering position of the car for any given frame the same as the physics position of the root bone?

I have an Nvidia 760M for the record.

more ▼

answered Feb 13 '15 at 02:01 AM

avatar image

straycodemonkey
6 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question