x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Additionnal mesh invisible in standalone only

I try to animate a blueprint character in sequencer. My character have 2 meshes, a Head and a Body, the default mesh is the head.

To simulate an absolute animation, I teleport my Actor in 0.0.0 before starting the sequence and play the animation.

In Editor, all goes right.

But in Standalone game, the body is invisible. I tweak a lot of options and the problem is : if the camera don't hit the capsule (which stay in 0.0.0) the mesh is invisible. If I grow the Bounds Scale, it works, but it's not a great solution.

I don't want to activate rootmotion, because I don't want physics blocking my character.

I don't understand why the head, the default mesh component works and not my additional component. And why only in standalone game...

If someone have some answer, that's great, I spent a weak on this "bug?"

Product Version: UE 4.13
Tags:
more ▼

asked Feb 14 '17 at 04:04 PM in Using UE4

avatar image

Vincent.Piedelou
36 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I found... after debugging the animation/visibility engine... eeek !...

  • The solution is to parent the additional mesh to the main mesh. So when we check the Use Parent Bounds, it works.

I don't know why, but when the engine calculate the mesh bound, it include the position of the capsule, so the bounds are bid enough to be seen. When calculating additional meshes, the parent root position is not added (and because the positions are 0 relative, the bounding are really small and centered on 0.0.0. So not visible if the camera don't look that way.

more ▼

answered Feb 15 '17 at 09:00 AM

avatar image

Vincent.Piedelou
36 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question