x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Google VR IOS Shipping build, crash after splash

Any ios shipping build generated with Google VR plugin enabled, came out damaged.

Splash screen start, and then the app close.

It looks somewhat related to Arm64, because developer builds just works fine, and the only difference, apparently, seems that developer builds are ArmV7 enabled by default.

Tested 4.14.3 and 415.0

Product Version: UE 4.14
Tags:
more ▼

asked Feb 15 '17 at 12:09 PM in Packaging & Deployment

avatar image

jined
51 4 5

avatar image jined Feb 19 '17 at 02:50 PM

Any idea?

avatar image GRADgr Jul 16 '18 at 01:10 AM

any progress on the issue? stil crashing on Black Project with Google VR Enabled

avatar image Seven莎温 Feb 20 '19 at 06:31 AM

ummm,4.21 Samsung's android phone, the s9, has the same problem。

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

I had similar symptoms when I built my app for Android with third-party plugin enabled. Please check in your project if all unused plugins are disabled.

more ▼

answered Feb 15 '17 at 02:54 PM

avatar image

Koralgoll
400 15 21 43

avatar image Rudy Q ♦♦ STAFF Feb 15 '17 at 08:10 PM

Hello jined,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

  4. What device are you currently using when you have this issue?

  5. What is the current OS being used on the device?

avatar image jined Feb 16 '17 at 07:58 AM

MACOS 10.12.3

iPHONE 7 10.2.1

1) Install unreal engine 4.14.3

2) Start a new blank project (i.e. First Person Demo), mobile, scalable, no content.

3) Plugins/Virtual Reality, remove all, activate Google VR, restart project

4) Project settings: package for SHIPPING, enable compressed cooking

5) IOS settings, create package demo.firstperson.com, options enabled: Package for iPhone only. All other options left as they are.

6) Registering new app id demo.firstperson.com, generating developing certificate, and developing provisioning.

7) Get back to Ue4, project settings, import the provisioning and certificate.

8) Build for IOS

9) Open XCode, push the .IPA package into iPHone7

10) Run the app FirstPerson, the splash screen start, then immediately, the splash screen close.

All the same, but DEVELOPMENT package, and the app starts normally.

If in development build, activate both ARM64 and Arm7, in IOS options, into project settings, and also the packaged Development IPA, crash after run.

avatar image Dan Unrealskills Jul 05 '17 at 05:31 PM

UE 4.16 - Development builds run well on iPhone 5s with both armv7 and arm64 turned on, but Shipping builds still crash after splash

(comments are locked)
10|2000 characters needed characters left

Got this problem too, did anyone resolved this? I am using 4.16 version

more ▼

answered Jun 29 '17 at 06:01 AM

avatar image

Dan Unrealskills
26 1 4 6

avatar image jined Jul 08 '17 at 12:45 PM

Yes, i've read somewhere that users moved ios compiling debug script settings, to the shipping script to get working ipa's with GoogVR enabled.

Development/Debug builds works quite well for testing, but they are not good for publish for a series of reason, including a different management of the provisioning that generates upload errors in the Application Loader, and last not least, presence of some Unreal tools and libraries for console command and debug purpose, but also the console command itself.

avatar image Dan Unrealskills Jul 08 '17 at 01:15 PM

I have posted a question in bug reports about it: https://answers.unrealengine.com/questions/662076/crash-on-ios-after-splash-with-googlevr-plugin-ena.html

So, i hope we'll get some new information about this bug, and I hope it will become "actual" from "duplicated"...

And yes, there is quite a workaround to publish development and re-signed version, but it is not good anyway.

So if it is VERY important for someone to publish the app "RIGHT NOW!", there is a working case: make dev. build, turn console by 4-tap off, resign ipa with distribution certificate and load to appstore. But the size will be very big. I made it for my project, because couldn't wait anymore. For iOS 8 app should be less than 100MB, iOS9 < 400MB, iOS10 <2 or 4GB...

avatar image jined Jul 09 '17 at 08:04 AM

Development builds have several cooking compression disabled, you may turn them on manually, and solve the size problems. Indeed, publishing development builds it is not yet the right solution, so we should push the team to fix this issue..

(comments are locked)
10|2000 characters needed characters left

Confirmed that still crashes on 4.20

more ▼

answered Jul 18 '18 at 07:31 PM

avatar image

GRADgr
88 3 4 8

avatar image rajpootathar Mar 18 '19 at 06:04 PM

still crashes on 4.20 i have not tried with 4.21

(comments are locked)
10|2000 characters needed characters left

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use the link provided for future updates. Thank you for your time and information.

Link: https://issues.unrealengine.com/issue/UE-42339

Make it a great day

more ▼

answered Feb 23 '17 at 10:31 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image jined May 31 '17 at 01:44 PM

This bug does not seems to be resolved, even in 4.16.0

avatar image Rudy Q ♦♦ STAFF May 31 '17 at 02:31 PM

This issue was marked as a duplicate of UE-41244. I have updated the public notes to show this change.

Link: https://jira.it.epicgames.net/browse/UE-41244

avatar image hirapong Jul 07 '17 at 01:36 AM

I got this problem too. using 4.16.2. Shipping builds crash after splash.

Build OS version: macOS 10.12.5

Testing device: iPhone6S (iOS 10.3.2)

Why is this issue marked as a duplicate of UE-41244? I think this problem is more serious than UE-41244 because we can't publish iOS app using GoogleVR plugin.

avatar image Dan Unrealskills Jul 07 '17 at 04:34 AM

The log from Xcode tells, that crash connected with this error: ShippingLog: [186] Jul 6 10:18:55 iPhone-Daniil SpringBoard(KeyboardArbiter)[212] : HW kbd: Failed to set (null) as keyboard focus

And it appears only with Shipping build and GoogleVR plugin enabled.

And I fully support hirapong: UE-41244 seems to be a different to this issue, especialy, UE-41244 - seems to be solved, because there is no crash with Switch button in UE 4.16.2

avatar image Dan Unrealskills Jul 03 '17 at 10:03 AM

Any workarounds yet?

avatar image Rudy Q ♦♦ STAFF Jul 05 '17 at 01:22 PM

Hello mister_dan,

I do not have a workaround for this issue at this time.

avatar image Dan Unrealskills Jul 06 '17 at 06:54 AM

I found, that the crash is somehow related to this iOS system error: "SpringBoard(KeyboardArbiter)[212] : HW kbd: Failed to set (null) as keyboard focus"

I made a new post and added crash and runtime logs for details. Maybe it can help.

https://answers.unrealengine.com/questions/672037/googlevr-ios-crash-after-launch-415-416-1.html

avatar image jined Jul 08 '17 at 12:40 PM

Correct, this is a serious bug and was introduced by 4.13, and yes, it is not related UE-41244.

Publishing is indeed possible with a workaround in v4.16.2...as long as it generates, working 64bit development/debug builds, some users managed to rid, moving many ios compiling script settings of the debug version, to the shipping version... but would be better, that shipping builds with Google VR enabled, would not crash.

Manipulation of compiling scripts may lead to unexpected results and probably not properly working .ipa's

avatar image Dan Unrealskills Jul 08 '17 at 05:02 PM

Do you know what script settings to move? Very interesting for me, because I tried different methods for 2 weeks with no success.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question