x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle migrated from Content Examples not colliding

Dear Answerhub,

From the 4.15 Content Examples, I had migrated the particle shown in the picture below into my own project.

The particle works fine in the Content Examples (Colliding with the spheres beneath it, in the Effects level), but I can't get it to collide with static meshes or landscapes in my own level.

Is there anything i'm missing?

alt text

I really could use some help, I just cant get my head around this issue...

Much love,

Unitrix

Product Version: UE 4.15
Tags:
untitled-2.png (1.8 MB)
more ▼

asked Feb 15 '17 at 07:23 PM in Using UE4

avatar image

Unitrix
117 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It would have been nice if you shown us the particle setup, as something must have changed.

  • make sure the emitter doesnt have local space enabled.

  • go to the projects settings, rendering menu and in the lighting tab you will see the "generate mesh distance field" option, turn it on, restart unreal. are the first two things that come to mind though.

more ▼

answered Feb 15 '17 at 07:44 PM

avatar image

Luos
8.8k 281 57 323

avatar image Unitrix Feb 15 '17 at 07:52 PM

Hi, thanx for the reply, I'm a big fan of your work!

The particle settings are identical, I have compared them side by side with the one in the in the Content Examples. Turning on Generate Mesh Distance Field didn't solve the problem after restarting the editor.

EDIT:

I must add: I created a new level and added some static meshes, the particle collided just fine. then i compared the world settings, but the world settings are identical aswell. The issue occurs on a level with a giant landscape instead of BSP's.

EDIT2:

I forgot to mention that this problem also occured on 4.14.

avatar image Unitrix Feb 15 '17 at 09:05 PM

Under the collision(scene depth) settings in the particle, I changed the setting from Scene Depth to Distance Field. (because you came up with the idea to enable the Generate Mesh Distance Field setting) That solved my problem partially. The particle collides with static meshes now but not with characters.

However: I'm very happy with the results! Thanx for your input! <3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question