x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cant save asset as unreal only partially loaded it

Warning Asset 'XXXXXX asset' cannot be saved as it has only been partially loaded

I dont understand Why would unreal only partially loaded an asset...... what does that even mean ?

Product Version: Not Selected
Tags:
more ▼

asked Jun 14 '14 at 12:52 PM in Bug Reports

avatar image

axelZellalex
51 5 8 11

avatar image Ben Halliday STAFF Jun 14 '14 at 07:21 PM

Hey axelZellalex,

Do you know which asset is causing this issue? Would you mind providing a test asset that causes the issue so we can take a look at it? Thanks!

Ben Halliday

avatar image gameme Jun 24 '14 at 02:38 AM

I am having the same issue now. Here is how it started,

  1. --first I was editing a class blueprint when the editor crashed

  2. And then I reopened the editor and it asked me if I wanted to recover the last open asset.

  3. I selected yes, but it failed to recover anyway,

  4. Now when I open the class blue print to edit stuff and save it, it say that "Warning Asset -- 'D:/Work/TwoPlayer/Content/Blueprints/BP_AI_Pawn.uasset' cannot be saved as it has only been partially loaded" -- PS: I lost all my work and had to restart the unreal editor again to fix it.

avatar image Ben Halliday STAFF Jun 24 '14 at 04:06 PM

Hey gameme,

Thank you for helping narrow down the cause of the issue. After restarting the editor, do you still get that warning?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi, erm it wasnt any asset in particular it seems im afraid

I closed the program down, and when I rebooted everything seemed fine.. Not sure what would have caused it/fixed it

more ▼

answered Jun 15 '14 at 04:28 PM

avatar image

axelZellalex
51 5 8 11

avatar image Ben Halliday STAFF Jun 16 '14 at 03:19 PM

I'm not certain either. Please let us know if it happens again, and maybe we can narrow the cause down. Thanks!

avatar image Hyperloop Oct 17 '14 at 03:51 AM

Repro steps for me seem to be:

1.Have the blueprint open

  1. Force quit or freeze the editor

  2. Restart editor and click yes when asked if you want to recover the assets

avatar image Ben Halliday STAFF Oct 17 '14 at 05:55 PM

Hey Hyperloop,

I tested this in 4.5 and didn't encounter the problem. I started a new project (Third Person BP template), opened the MyCharacter Blueprint, and used the Task Manager > End Task on the engine. When I reopened the project and chose to recover assets, the BP opened as expected.

Are you in 4.5 or an earlier version of the engine? You mention Force Quit... are you using a Mac? Does this happen in a new project or only your current project? And does it happen consistently? Thanks!

avatar image Ben Halliday STAFF Oct 21 '14 at 07:56 PM

Hi Hyperloop,

We haven't heard back from you in a few days, so I'm going to mark this as resolved for tracking purposes. Please reopen with the information requested above and we will continue investigating. Thanks!

avatar image RAVaught Nov 25 '14 at 11:35 PM

Ben, I can confirm that this is still an issue in 4.5.1 using Tortoise SVN.

avatar image Ben Halliday STAFF Nov 26 '14 at 08:14 PM

Hi RAVaught,

Can you provide any additional details? Are your repro steps similar to Hyperloop's, or to piinecone's?

avatar image piinecone Aug 13 '14 at 06:20 PM

I'm able to reproduce this somewhat consistently in projects with Perforce source control. Since I'm using assembla, sessions don't persist for more than 12 hours. If I open up an asset in UE4, modify and save it, then connect to source control and try to save it again, I get the "cannot be saved / partially loaded" message. The only way to resolve this is to restart the editor, discarding any changes. It appears that this only happens when I forget to immediately connect to source control upon opening a project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I know this is old, but I wanted to put my fix here for others. I had this issue when I made an asset then my editor crashed before it could save it. After relaunching the editor and trying to remake the asset I was given this message. Restarting the editor etc didn't fix this. As a note perforce is used with this project, but it didn't end up being related to the issue. I went into my folder where the asset would be if it would let me create it and guess what it was there already, though it didn't show up in the editor. So I just deleted it and was able to remake in the editor no issue. Hope this helps someone.

more ▼

answered Jun 15 '16 at 08:55 AM

avatar image

MOS99Z
326 6 6 11

avatar image Fluppi393 Jul 12 '16 at 03:06 PM

Thanks mate that helped.

avatar image TorQueMoD Apr 04 '17 at 08:20 PM

This also helped me and I'm not using Perforce.

avatar image JonathanArmstrong Apr 21 '19 at 06:10 PM

Renaming the asset from the content browser also fixes this issue.

avatar image mrmeen 6 days ago

This should be at the top. Works everytime. Quick fix.Just rename.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question