x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Static lights disappear after baking?

Hey there!

I have problem with my lights building. I've both static and stationary lights in the scene. All the stationary lights are baking fine, but static lights do not at all like they've never exist. I've read all threads about lighting issues and their solutions on Unreal's Answers but none of them helped yet.

• My scene is originally created with 4.12.5 version (but I tried to open it on 4.14.3 and same problem happen)

• Machine: i5-2500K / GTX 970 / 32GB RAM / Windows 7 System

• All the lightmap stuff like resolutions, UV's etc are properly set.

• Tried to bake static point lights on a new blank level with some BSPs and it WORKED.

• The only warning I get after bake is: "SkySphereBlueprint Collision enabled but StaticMesh (SM_SkySphere) has no simple or complex collision."

Would be super-grateful for any suggestions, Thank you.

Product Version: UE 4.12
Tags:
more ▼

asked Feb 17 '17 at 12:25 PM in Rendering

avatar image

SamirDuran
1 1 2 1

avatar image Raildex_ Feb 17 '17 at 09:48 PM

Do your Static Meshes have proper Lightmaps and the Resolution of them is high enough?

avatar image SamirDuran Feb 18 '17 at 12:11 PM

Yes, of course, like I wrote above, it's all set properly.

avatar image Digdugxx Jun 29 '17 at 02:43 AM

In case you guys are still having issues, try checking project settings that static lights are enabled:

project settings, allow static lighting

Next thing to check is that you aren't an idiot like me who disabled baked lighting ._.

alt text

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Do you have reflection capture sphere place in the scene?

more ▼

answered Apr 18 '17 at 02:41 PM

avatar image

isayitsok
1

(comments are locked)
10|2000 characters needed characters left

I am having the same issue. I've found that if I change the attenuation value, then set it back to what it was, the lights pop back on.

It's super annoying to have to do this every time after you bake.

If anyone has a better method, please let me know.

edit: This is in 4.16

more ▼

answered Jun 25 '17 at 12:51 PM

avatar image

Vall Forran
1 2

(comments are locked)
10|2000 characters needed characters left

click on one of the lightmaps and save it, then close that window and click the scene.

more ▼

answered Aug 20 '17 at 03:54 PM

avatar image

jldevoy
56 2 3 7

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question