x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android packaging error

So I have this error message at the end of the log. Up until this point everything seems to go fine, so I'm posting the section that produces the error. Other similar posts that I came across had different messages and mostly error code 5 for the automation tool, but I have 1. Things I tried: -building in 4.14 -installing debugging symbols -reinstalling udk4 -building for windows(it worked) I just don't know what to do with this pls halp :|


UATHelper: Packaging (Android (All)): UEDeployAndroid.UpdateGameActivity: UATHelper: Packaging (Android (All)): ==== Writing new GameActivity.java file to E:\a UnrealShiat\Phone3rdpersMkII\Intermediate/Android/APK\src\com\epicgames\ue4\GameActivity.java ==== UATHelper: Packaging (Android (All)): UEDeployAndroid.MakeApk: UATHelper: Packaging (Android (All)): Copying new .so D:\UDK\Epic Games\UE_4.15\Engine\Binaries\Android\UE4Game-armv7-es2.so file to jni folder... UATHelper: Packaging (Android (All)): UEDeployAndroid.RunCommandLineProgramWithException: Preparing native code for debugging... UATHelper: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: ERROR: D:/Program Files (x86)/CodeWorks4Android/android-ndk-r12b/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1 UATHelper: Packaging (Android (All)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown) UATHelper: Packaging (Android (All)): BUILD FAILED PackagingResults:Error: Error Unknown Error


ps: I can't get this thing to format things neatly :(

Product Version: UE 4.15
Tags:
more ▼

asked Feb 17 '17 at 03:51 PM in Packaging & Deployment

MrWayash gravatar image

MrWayash
3 1 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I think this is happening because of the space in the "Program Files" in the install directory of CodeWorks

ERROR: D:/Program Files (x86)/CodeWorks4Android/android-ndk-r12b/ndk-build.cmd

I read somewhere before that the path should not contain spaces. So basically you should not install it in Program Files folder

Try Installing the NVPACK in a different location a custom folder say called "NVPACK"

Like mine reads like D:\Me\Softwares\NVPACK (Notice no space)

Please make your necessary back-ups. This a just a suggestion solution. You will try it at your own risk, so do not blame me if you mess somthing up.

To do a clean re-install without downloading -

  1. Just copy the "CodeWorksforAndroid" folder which contains folders like "001","002" etc. to a location.

  2. Go to the install folder and run "uninstaller" program

  3. After finished Go to engine-version\Engine\Extras\AndroidWorks\Win64\CodeWorksforAndroid.

  4. Go through the wizard and download some small document in the "Chooser" and finish (others you can select "no action" option). (Make sure to change the default install location this time.)

  5. Restart the PC at the end of the wizard when pop-up asks you.

  6. Copy the CodeWorksforAndroid folder that you backed up in step one and overwrite the one in the newly installed folder.

  7. Run "Chooser" and install.

Cheers!

more ▼

answered Feb 17 '17 at 04:32 PM

Shobhitthackar gravatar image

Shobhitthackar
252 10 5 12

MrWayash gravatar image MrWayash Feb 17 '17 at 04:39 PM

<3 will try it now

MrWayash gravatar image MrWayash Feb 17 '17 at 05:02 PM

:'D The codeworks uninstall crashes when I start it because of the spaces in the file name

Shobhitthackar gravatar image Shobhitthackar Feb 17 '17 at 06:06 PM

Darn man, I am pretty sure that the solution to your problem is fixing the path. But since uninstaller is not working again due to the path. I don't know about a clean uninstall.

Try uninstalling via program and feature -> uninstall a program -> It should have NVDIA CodeWorksforAndroid.

Also, just for your info. All the downloaded stuff is under the folder I mentioned in step 1. So you should be safe as far as it goes for downloading if you back it up.

MrWayash gravatar image MrWayash Feb 17 '17 at 10:19 PM

unfortunately the programs and features option did not work either. I managed to start it somehow however, after downloading an installer from their website, deleting some stuff, rebooting, crying, it somehow worked. Now I'm having some weird file access nonsense within codeworks. :D It's amazing how much one has to suffer with theese kinds of things. Thanks for the help by the way!

MrWayash gravatar image MrWayash Feb 18 '17 at 09:26 AM

It worked! Thank you very much!

Shobhitthackar gravatar image Shobhitthackar Feb 18 '17 at 11:46 AM

Good one! Quite a heckle ride. Glad could help. Now go back coding as will I :D

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question