x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Black artifacts and outline artifacts in editor viewports

I get black artifacts in the editor viewport. It's like anything forward-rendered (the UI mainly) gets "stuck" but with a black color. Like some buffer is not cleared correctly.

This happens in both lit and unlit mode, the only mode that is working correctly is wireframe. I can temporarily "clear" the blackness by switching to and from wireframe mode, but as soon as the camera transform is changed again, more blackness shows up.

This issue is more prone to happening in lower viewport sizes/resolutions. If I resize the viewport to make it bigger (or go fullscreen), the issue pretty much disappears. However, when I do this, I notice another issue; The "masking buffer" for the yellow actor selection outlines doesnt seem to get cleared either. When I rotate the camera view, the outline just grows according to where the selected actor is, but it doesnt disappear where it isnt.

This doesnt seem to happen in PIE/play mode.

EDIT: This doesnt happen either if I check "Game view"

Please poke me if you need more information or any clarifications.

System informaiton:

 Arch Linux x86_64
 Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz
 Intel HD 530
 8GB DDR4 RAM
 
 [2017.02.18-14.23.37:824][  0]LogRHI:   GL_VENDOR: Intel Open Source Technology Center
 [2017.02.18-14.23.37:824][  0]LogRHI:   GL_RENDERER: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 
 [2017.02.18-14.23.37:824][  0]LogRHI:   GL_VERSION: 4.5 (Core Profile) Mesa 17.0.0
 [2017.02.18-14.23.37:824][  0]LogRHI:   GL_SHADING_LANGUAGE_VERSION: 4.50
 
 LogInit: Build: ++UE4+Release-4.15-CL-0
 LogInit: Engine Version: 4.15.0-0+++UE4+Release-4.15
 LogInit: Compatible Engine Version: 4.15.0-0+++UE4+Release-4.15
 LogInit: Compiled (64-bit): Feb 18 2017 14:52:59
 LogInit: Compiled with Clang: 3.9.1 (tags/RELEASE_391/final)
 LogInit: Build Configuration: Development
 LogInit: Branch Name: ++UE4+Release-4.15

Product Version: UE 4.15
Tags:
more ▼

asked Feb 18 '17 at 02:49 PM in Bug Reports

avatar image

Fredrik.Haze
16 3 5

avatar image ohookins Feb 19 '17 at 08:08 PM

Anything like this? alt text

avatar image Fredrik.Haze Feb 19 '17 at 09:59 PM
avatar image ohookins Feb 20 '17 at 08:11 PM

OK, that looks nothing like what I get.

avatar image Doug E ♦♦ STAFF Feb 21 '17 at 01:23 PM

Hey Fredrik-

I do not see the same results in a new project on my end. Can you try updating your graphic drivers for me? Additionally, can you let me know what your Engine Scalability Settings and Preview Rendering Level are set at? You can find both of these in the Settings dropdown at the top of the viewport.

avatar image Fredrik.Haze Feb 21 '17 at 01:41 PM

I use the latest xf86-video-intel package on Arch Linux (xf86-video-intel 1:2.99.917+757+g93942b7d-1) in combination with the latest mesa packages (mesa and mesa-libgl 17.0.0-1). If you use Ubuntu or something, these versions (or newer) will inevitably come to those distros some time in the future as well.

Engine Scalability is set to low, changing the resolution scaling doesnt affect the issue. Setting scalability to high or above just gives me a completely black viewport.

Preview rendering level is set to SM5. I tried setting it to SM4, but now the editor doesnt respond. Will leave my laptop for a few mins and respond later.

Reading up on the wiki it's apparently recommended these days to ditch the xf86-video-intel and go with the bare modesetting driver. I will try this and come back to you.

avatar image Fredrik.Haze Feb 21 '17 at 02:06 PM

No change without xf86-video-intel. Now I just use the standard mesa and kernel drivers.

 Device: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)  (0x191b)
avatar image Fredrik.Haze Feb 21 '17 at 01:55 PM

SM4 gives a completely corrupted viewport (looks like it just renders uninitialized buffers or something, random memory regions).

avatar image jasoncunsw Mar 20 '17 at 10:29 PM

Currently using UE 4.15 and have an issue where the viewport screen displays black artefacts (which flicker both when editing and when Playing in Editor)

The other issues are that selected objects are highlighted even when highlight colour is set to transparent and the game object icons are chequer boarded at all times as though selected.

UE 4.14 was OK on the same iMac (Intel Iris Pro Graphics 6200).

It seems to be an incompatibility issue with the Intel Iris Pro Graphics 6200 as another iMac with Nvidia graphics don’t display the issues.alt text

artefacts.png (231.5 kB)
avatar image Doug E ♦♦ STAFF Mar 29 '17 at 04:05 PM

Hello jasoncunsw-

Can you provide the drivers that you're on? If you are still seeing this issue, please try upgrading to the latest released drivers. Additionally, if you're using an integrated card (which the Intel Iris Pro is) then it is recommended that you have more than 8g of RAM.

avatar image alko1989 Apr 02 '17 at 10:06 AM

Same issue here using Intel HD 5500 on Arch with xf86-video-intel drives.

avatar image Doug E ♦♦ STAFF Apr 05 '17 at 06:06 PM

Hey Alko1989-

We have still not seen this reproduce locally. If possible, could you provide a project that shows this behavior for me to test on my end?

avatar image alko1989 Apr 06 '17 at 06:30 PM

Its my first project in UE, its just a side scroller from wiki tutorial. I don't think the issue is related to the project itself, this occurs on any new project. The behaviour is exactly as shown on the video Frederik provided.

I also tried projects from Unreal course with the same result.

I did compile the engine with clang 3.9.1 or clang package in Arch instead of required clang35. But I can't use the other since it breaks other dependencies on my system. And it compiled without errors.

avatar image Fredrik.Haze Apr 06 '17 at 06:35 PM

Hey Doug! I am certain that this is not a project issue. Are you sure you are using the same setup? If would guess the same versions for the gpu driver, X11 etc would make a lot of difference.

avatar image pepper_chico Apr 17 '17 at 12:25 AM

I have the same issue on ArchLinux as well using Intel Graphics. I started UE 4.15.1 for the first time and created a project based on the ThirdPerson sample project. Once I move in the scene the black artifacts are left behind like if the buffer isn't being cleared, the more I move, the more clutered the scene gets. I've installed on ArchLinux through https://aur.archlinux.org/packages/unreal-engine.

avatar image pepper_chico Apr 17 '17 at 12:28 AM

My issue is the same as in the video posted on YouTube. I'm running a 7700K.

avatar image alko1989 Apr 17 '17 at 01:20 PM

Doug, you might be able to reproduce this by disabling the external graphics card and use the integrated Intel graphics. If you can do this on your machine. Every new Intel cpu comes with the integrated graphics card.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey everyone,

Though I have not reproduced this personally, I have gone ahead and entered a report for this issue based on the information provided: https://issues.unrealengine.com/issue/UE-44099 . You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Cheers

Doug Wilson

more ▼

answered Apr 18 '17 at 02:36 PM

avatar image

Doug E ♦♦ STAFF
51.1k 777 26 571

avatar image pepper_chico Apr 18 '17 at 03:50 PM

@Doug, I think the report can add that this happens when using Intel Graphics, I think everyone complaining here is using it.

avatar image Doug E ♦♦ STAFF Apr 18 '17 at 03:53 PM

To help us, can you provide your logs from the project after this occurs. Those could help point to where this problem is occurring.

avatar image Fredrik.Haze Apr 18 '17 at 04:16 PM

I agree with pepper chico, this seems to happen with the latest intel driver on Linux. Have you tried to reproduce it using arch linux?

I have attached my log here

Is there anything further I could do to try and narrow it down? Pressing F11 to enable fullscreen in the viewport seems to remove the issue for me.

ue4log.txt (25.3 kB)
avatar image Fredrik.Haze Apr 18 '17 at 04:18 PM

Also, the problem isnt showing up in PIE either

avatar image pepper_chico Apr 18 '17 at 04:51 PM

How/where I get the logs?

avatar image Doug E ♦♦ STAFF Apr 18 '17 at 05:35 PM

The logs can be found in the [ProjectName]/Saved/Logs folder. The best approach would be to cause the issue to occur, then shut down the editor and attach the most recent .log file from that folder.

avatar image pepper_chico Apr 18 '17 at 06:12 PM

Here are the logs, I've just opened a new project based on the rolling sample, moved a bit in the scene, the issue reproduced like in the youtube video, then I closed the editor.

samplerolling.log (134.0 kB)
avatar image Schroedingers Cat May 01 '17 at 07:19 AM

I also have this problem on Ubuntu 17.04 with an i5-3380M (HD3000) on UE 4.15.1 with Mesa version 17.2 (OpenGL 4.2, so I have to run UE4 with -opengl3). With UE 4.14.3 these artifacts don't show up, so it is something that has been added somewhere during UE 4.15.1 or UE 4.15.

avatar image pepper_chico Aug 09 '17 at 06:47 PM

I have just installed Unreal Engine 4.17 and the black artifacts have just turned into orange artifacts... At least they don't clutter the view so badly as before.

@Doug, do you happen to know to what issue UE-44099 has become a duplicated of? I've seen that UE-44099 has been marked duplicate, but can't find the original.

avatar image pepper_chico Aug 09 '17 at 09:39 PM

Screenshot after just opening the Vehicle sample and zooming out the viewport:

Artifacts

avatar image Doug E ♦♦ STAFF Aug 15 '17 at 04:05 PM

Hey peppre_chico-

UE-44099 was marked as a duplicate of https://issues.unrealengine.com/issue/UE-43725 which appears to have been fixed for 4.16. If you are still seeing this behavior in 4.17, it may be that this was fixed on the Mac side and not Linux. I have reached out for further clarification on this.

For additional information, are you using an Intel graphics card in your machine? Additionally, if you uncheck the "Support Forward Rendering with Metal" checkbox in the Engine/Cooker section of the Project Setting, do you notice any difference after restarting the project?

avatar image pepper_chico Aug 15 '17 at 06:20 PM

Hi @Doug, yes I'm on a 7700K ArchLinux PC on Intel Graphics solely. There's no such option in the menus from my side.

avatar image pepper_chico Aug 15 '17 at 06:23 PM

Also, I don't know how the bug thread here remotely relates with UE-43725, I have no flickering issues and it's not mentioned here, the issue has been just artifacts left behind, like not properly clearing the graphics buffer.

avatar image Doug E ♦♦ STAFF Aug 16 '17 at 12:34 PM

After speaking with other developers, I found that UE-43725 was a Mac specific fix. I have reopened UE-44099 for further investigation.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question