x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I can't build for Android []

I can't package for Android. I've had this problem with other versions as well. Every time the packaging will stop and gives me this error:

 Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

I've tried uninstalling and reinstalling UE4, Visual Studio Community 2015 and Android SDK.

I'm not using any plug-ins and this even happens with brand new projects based on templates without changes.

I made sure Project Settings > Platforms > Android > APKPackaging says "Platform files are writeable" and is green. I have the latest versions of Android SDK and the JDK.

Every time I feel like I need to give up before losing my mind. Unity successfully builds for android so I know it can't be the Android SDK. I just don't know what else to do.

Please, help me. Please.

Here is the whole output log of the packaging on a txt.

And this is my computer:

  • CPU: AMD Phenom II X6 1055T

  • GPU: Asus GTX 970

  • Windows 64-bit

Product Version: UE 4.15
Tags:
build failed.txt (217.5 kB)
more ▼

asked Feb 20 '17 at 01:07 AM in Packaging & Deployment

avatar image

makhras
6 1 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Could you please provide the following screen shots -

Packaging settings->Project Settings, Android SDK settings and Android settings.

Are you packaging "for distribution"?

In your log this is where things go wrong -

UATHelper: Packaging (Android (ATC)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.DirectoryNotFoundException: No se puede encontrar una parte de la ruta de acceso 'C:\Users\Michael\AppData\Local\Android\android-sdk\extras'.

Based on my fall and learn knowledge of packaging for android.

more ▼

answered Feb 20 '17 at 03:54 AM

avatar image

SHOBBIT
650 13 13 28

avatar image makhras Feb 20 '17 at 04:34 AM

Thank you! I'm not packaging for distribution.

Here are my screenshots:

packaging settings

android settings

android SDK settings

Sorry I didn't provide screenshots before.

Also, here's my AppData/Local/Android:

SDK dir

I don't know if there should be that many sdk folders.

sdk directory.jpg (11.6 kB)
avatar image makhras Feb 20 '17 at 05:52 AM

Apologies. As you can tell, I know almost nothing about programming.

Your pointing out that there's an "extras" folder missing made me try the other sdk folders. Those do have an "extras" inside.

Also, I just realized I wasn't pointing at the JDK directory at all.

And that did it! All I had to change was this:

sucess!!

Thank you so much!

build success.jpg (37.4 kB)
avatar image SHOBBIT Feb 20 '17 at 12:38 PM

Cheers man! From working with android I have learn't that most of the packaging issues arise from not correctly setting up the Android SDK. Great to know you got it working!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question