x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Nativisation issue: fatal error on run project

Hi there - I can compile my project fine (both normally and with nativisation), but when nativising, even exclusively one simple blueprint, I get the following error when attempting to run the packaged game:

Fatal error: [File:C:\Unreal4_15_0Source\UnrealEngine-release\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 1558] FAsyncPackage::FindExistingImport class mismatch EnumProperty != ByteProperty

KERNELBASE.dll!0x0000000056377788 SN2CPP.exe!0x00000000B0FD41BA SN2CPP.exe!0x00000000B0DF78AA SN2CPP.exe!0x00000000B0D7D428 SN2CPP.exe!0x00000000B1058607 SN2CPP.exe!0x00000000B106D605 SN2CPP.exe!0x00000000B1055B7E SN2CPP.exe!0x00000000B1031AEF SN2CPP.exe!0x00000000B1070CAE SN2CPP.exe!0x00000000B107777B SN2CPP.exe!0x00000000B109836F SN2CPP.exe!0x00000000B10974D8 SN2CPP.exe!0x00000000B105DE45 SN2CPP.exe!0x00000000B11F0ACA SN2CPP.exe!0x00000000B11F0339 SN2CPP.exe!0x00000000B1208CFB SN2CPP.exe!0x00000000B1213C71 SN2CPP.exe!0x00000000B1213193 SN2CPP.exe!0x00000000B2EA8138 SN2CPP.exe!0x00000000B0C0A8B8 SN2CPP.exe!0x00000000B0C0A022 SN2CPP.exe!0x00000000B0C0A19A SN2CPP.exe!0x00000000B0C1B4D8 SN2CPP.exe!0x00000000B4C7961B KERNEL32.DLL!0x0000000056D38364 ntdll.dll!0x00000000591670D1 ntdll.dll!0x00000000591670D1

Any advice would be fantastic. Many thanks, Lawrence

Product Version: UE 4.15
Tags:
more ▼

asked Feb 19 '17 at 11:13 PM in Packaging & Deployment

avatar image

2sneaky
6 1 2 6

avatar image PhroZenOne Feb 22 '17 at 06:24 PM

Did you manage to resolve this? We have run into the same problem with class mismatch EnumProperty != ByteProperty.

avatar image 2sneaky Feb 24 '17 at 01:22 AM

No resolution yet mate - fingers crossed Epic can find the cause :)

avatar image Steve Hardister ♦♦ STAFF Feb 23 '17 at 08:23 PM

Hi 2sneaky,

What is the Platform you are Packaging for?

In your Project Settings, are you using Inclusive or Exclusive Nativization?

Are any of the Blueprints Level Blueprints or Blueprint Macros?

Please provide this information and we will continue to investigate.

Thanks,

Steve H.

avatar image hls333555 Feb 25 '17 at 12:29 PM

I have run into the same error here...

avatar image mellowsoft Apr 24 '18 at 05:41 AM

Hey Steve, Any word on this bug?

Packaging for PC Exclusive Nativization None of them are level or macro blueprints.

Super frustrating because this is the only place on the internet with this specific bug mentioned...would really like to use BP nativization :(

avatar image 2sneaky Feb 24 '17 at 01:10 AM

Hi Steve, thanks for the reply! I am packaging for Win64, using Exclusive nativisation.

The easiest way to reproduce it is to nativise the BP_PlayerCharacter blueprint from the Generic Shooter marketplace addon. I have not tried to nativise level or macro blueprints.

Looking forward to hearing from you again, best of luck trying to find the cause! if you need any more info dont hesitate to get in touch. Lawrence

avatar image mellowsoft Apr 13 '18 at 03:13 AM

Hey guys, I'm running into this problem as well. Project builds fine with exclusive blueprint nativization. I'm on 4.18.2. Running the packaged game gives the LowLevelFatalError, AsyncLoading.cpp, FAsyncPackage::FindExistingImport class mismatch ByteProperty != EnumProperty error.

Disabling nativisation fixes the issue and the packaged game runs fine.

avatar image mellowsoft Apr 13 '18 at 04:38 AM

By changing from exclusive to inclusive it seemed to fix this error. I am running into some different errors on some machines with blueprint nativization, seems to be a pretty buggy feature sadly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi 2sneaky,

It took a while to coordinate getting the Generic Shooter authorized to check out for testing nativisation. My results following your repro steps were (Following steps for Exclusive Nativization):

 UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.07-19.55.54:467][  0]LogInit:Display: LogBlueprintCodeGen:Error: BP /Game/GenericShooter/BlueprintLogic/BP_PlayerCharacter.BP_PlayerCharacter is selected for nativization, but BP interface class /Game/GenericShooter/BlueprintLogic/Interfaces/BPI_CanOverrideDamage.BPI_CanOverrideDamage_C is not 

When I nativised that file, it would not successfully compile due to other erros so I attempted to repro the issue by nativising the ThirdPersonCharacter Blueprint from the Third Person Blueprint project template. (Note that the Generic Shooter is currently not tested/approved for UE4.15 so this may be the cause of the issue.)

This compiled successfully with the nativised asset, so the issue does not appear to be with a bug with nativisition per se, but something that needs to be adjusted in the Generic Shooter file to work with nativization.

If you can reproduce the issue with a project that is meant to work with UE4.15 specifically, we will continue to investigate the issue.

Thanks,

Steve H.

more ▼

answered Mar 07 '17 at 09:31 PM

avatar image PhroZenOne Mar 07 '17 at 11:25 PM

I have the same error when running a nativized project. I have tried to reproduce it on a new project but failed, it may have to do that I run a converted old project (Started building my game with version 4.7).

I could give you access to our current project that shows this behavior when trying to nativize but it is currently close to 10GB uncompressed. If that's the case then how do I get in contact with you directly? As I don't want to add a link here for everyone to download. :)

avatar image 2sneaky Mar 12 '17 at 01:05 AM

Hi Steve H, thanks for your attempt, but you seem to have missed the issue - I was able to compile and nativize without errors. the errors occurred when the successfully packaged build was run. Also - what do you mean by designed for 4.15 specifically? there is no guidelines for nativisation regarding what is and isnt supported per se, so if my project which runs perfectly in all aspects in 4.15 apart from nativisation, errors when running the nativised build it sounds like its an issue with the engine. If not, please can you point me to any documentation regarding what is, or isnt, supported by nativisation. Judging by the other comments I am not the only person who is having the issue so being told to try to reproduce it by recoding my entire project from scratch in 4.15 with no documentation as per what to look out for while aiming for nativisation still leaves us up the proverbial creek with no paddle. Regards, Lawrence

avatar image PhroZenOne Mar 12 '17 at 07:54 PM

2sneaky: I think Steve means that the Generic Shooter template does not work in 4.15 without changes, so he wonders if you can convert the Generic Shooter to a 4.15 build that stills shows the error. That would at least be a bit smaller than my 10GB project to work with.

My guess is that it has something to do with convertion of enums from an old project ( < 4.15 ) to a 4.15 project and then nativizing it. But that's just pure speculation on my part.

avatar image 2sneaky Mar 13 '17 at 03:17 AM

@phrozenone sounds like a plan, I'll whip one up

avatar image Steve Hardister ♦♦ STAFF Mar 15 '17 at 08:49 PM

If it wasn't clear, I did run my packaged test after nativizing the 3rd Person Blueprint without errors or crashing. I was not, however, able to package the Generic Shooter due to a large number of errors, so I could not test the packaged results.

Since I'm assuming that when you don't nativise you are not getting the error when attempting to run your packaged game, the best way to resolve this is to compare apples to apples so to speak.

To that end, if you would be willing to send a copy of your project for testing, you can send a link to your zipped file on Dropbox, Google drive, etc in a private message to me on our Forums. This would help get to the root of the problem significantly faster.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question