Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level streaming doesn't work after package

Hi, Over the past few months I have been developing a game for a high school school competition. Originally the due date was going to being march 23rd a month from now but 2 days ago I was informed that they changed the due date to Tuesday(tomorrow) and I still have a game breaking bug. I'm relatively new to unreal engine 4 and I most likely made some rookie mistakes. In this game, the player has to fix an elevator engine and when that happens the player is prompted to go to the elevator to proceed to the next level. That happens through level streaming and teleporting. In the Editor the player can successfully finish this level and proceed into the next level with little to 0 problems 98% of the time. But when the game is packaged and the player completes the objective and heads into the elevator the trigger gets fired showing a loading screen widget and then a couple of seconds later the player appears back into the elevator like nothing happened no level change what so ever. The First Picture is in the Player what handles the loading and the 2nd picture is what the player runs into that calls it .alt text alt text Any help is apperatied i have to have a working packaged game in the next 3 hours or we are at a loss

Product Version: UE 4.14
loading bp.png (131.3 kB)
engine.png (159.3 kB)
more ▼

asked Feb 21 '17 at 02:56 AM in Packaging & Deployment

avatar image

6 2 4

avatar image AftersunFPS Apr 14 '17 at 11:13 PM

Have you found the solution to this problem? Were currently experiencing this issue with our tiled world.

All the regions are loaded in the editor. The sub levels are all flagged with ALWAYS LOADED but when packaging none are present?

avatar image Huolynn Jul 17 '17 at 07:55 AM

Hava you found the solution? The same problem!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I tried loading the content exemple from epic. They have a level streaming exemple. I tried packaging it and it works. Ill study whats different between my project and theirs.

more ▼

answered Apr 17 '17 at 02:12 PM

avatar image

21 1

avatar image theonecalledtom May 01 '17 at 03:51 AM

Any pointers? I just tried 4.15 and none of my levels are streaming. Going to start digging but any shortcuts appreciated!

avatar image theonecalledtom May 03 '17 at 04:06 PM

My problem is likely due to the way I mount pak files. Looks like level streaming breaks after I mount a DLC pak file.

avatar image Huolynn Jul 17 '17 at 07:56 AM

Have you solved the problem?

avatar image AftersunFPS Jul 17 '17 at 03:19 PM

i gave up and redid the map as 1 big chunk.

avatar image Sean L ♦♦ STAFF May 04 '17 at 05:21 PM

Hey theonecalledtom,

If you are able to verify that the issue is related to mounting a pak file, please open a new thread in the Bug Reports section with a detailed list of repro steps so we can investigate as a separate issue.

Have a great day!

avatar image jeffwinner Nov 08 '17 at 02:20 PM

I have the this issue when i package my game too!

My levels are simple : main level with lights, skylight and skysphere / splashscreen/ loading / TheFarm with the first chapter of the game and all features, terrain houses, trees etc. When I play from the editor, it works, but when I package it, it just loads the main level. * YES I CREATED STREAMING VOLUMES AND MADE THEM ASSOCIATED!

avatar image Sean L ♦♦ STAFF Nov 08 '17 at 08:19 PM

Hey jeffwinner,

Can you provide your project logs from a packaged development build of your game as well as from your PIE session so I can take a look?

avatar image jeffwinner Nov 08 '17 at 08:22 PM

Sadly I'm in the end of my deadline to release my demo. I just removed the streaming levels and made it all work in the persistent. I can't send the log because it doesn't exist anymore. :( When i start the full version of my game I'll try it again! Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users


After reading your post, I see that you were on a strict deadline. Were you able to resolve this issue in time? If not, would you still like some assistance in looking over your level streaming?

Check out our Content Examples too under the Learn tab in the Epic Games Launcher. There is valuable information in there about level streaming.

Looking forward to hearing back from you, thanks!

more ▼

answered Feb 28 '17 at 04:05 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question