x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project crashes on startup - corrupted map?

Hello everyone,

So for some reason, I have a project that radomly decides to crash on startup, whic I have narrowed down to the maps in the project, somehow gets corrupted.

When I open the project, I get the following error log:

 [2017.02.21-06.49.57:486][  0]Cmd: MAP LOAD FILE="../../../../../../Temp_UE4/ClientConferenceVR/Content/Maps/Products/LVL_Vacon3000.umap" TEMPLATE=0 SHOWPROGRESS=1 FEATURELEVEL=3
 [2017.02.21-06.49.57:487][  0]LightingResults: New page: Lighting Build
 [2017.02.21-06.49.57:527][  0]MapCheck: New page: Map Check
 [2017.02.21-06.49.57:527][  0]LightingResults: New page: Lighting Build
 [2017.02.21-06.49.57:865][  0]LogWindows: Windows GetLastError: The operation completed successfully. (0)

Full log

I've tried deleting the saved/intermediary folders with no luck. If I reset my DefaultEngine.ini to open the default editor map, the project loads fine, but as soon as I try to load some of my levels, it all comes crashing down. This is the second time this has happened to me, and last time my only solution was to revert 5 hours of work with Source Control - I would love to avoid that in the future.

Product Version: UE 4.14
Tags:
errorlog.txt (32.6 kB)
more ▼

asked Feb 21 '17 at 06:58 AM in Bug Reports

avatar image

Zpanzer
28 1 2 8

avatar image Steve Hardister ♦♦ STAFF Feb 23 '17 at 06:53 PM

Hi Zpanzer,

I do not see any recent crashes from you in our Crash reporter data. Can you please hit the Submit button on the Crash Reporter window next time this happens and include some notes in the description field regarding what you were doing at the time of the Crash.

Also, do you have any UMAP fifes in your Saved folder. (They would have to be from a backup of before you deleted the intermediate and saved folders.) If available, copy the saved UMAP files to the Content Browser, then launch and save those new levels.

Try these steps and let me know if you are not able to recover and save from your backed up files.

Thanks,

Steve H

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Steve,

Thanks for taking the time to answer.

So after an hour or so, I found the problem. I edited the DefaultEngine.ini to make the project start up in UE4 default template scene. The projected loaded fine and then I did the following:

Open map -> Crash

Open maps GM -> Crash

Open maps Pawn -> Crash

Open blueprints associated with Pawn -> crash

In the end, I found out my blueprint for VR controllers were the culprint. For some reason, that specifik blueprint got corrupted when I tried to cast from it to another specific blueprint. Never understood why.

more ▼

answered Feb 23 '17 at 09:40 PM

avatar image

Zpanzer
28 1 2 8

avatar image Steve Hardister ♦♦ STAFF Feb 23 '17 at 10:04 PM

Thanks for taking the time to provide the resolution to your issue. Excellent troubleshooting steps that will likely help someone else in a similar situation.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question