x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaging Linux ARM64, exec format error

I'm trying to package on Windows for Linux ARM64 (Jetson running Ubuntu). I have 4.15 (installed from Epic Game Launcher) and did all the steps:

  • Used latest clang cross compiler (3.9.0)

  • set both LINUX_ROOT and LINUX_MULTIARCH_ROOT to correct paths

  • changed DefaultEngine.ini in my project to have the section: [/Script/LinuxTargetPlatform.LinuxTargetSettings] TargetArchitecture=AArch64UnknownLinuxGnueabi

I managed to package the project, but couldn't run it on Linux. I tried to run the file UE4Game in LinuxNoEditor\Engine\Binaries\Linux, but I got an error:

"Cannot execute binary file: Exec format error".

When I looked at the file properties, it wrote:

ELF 64-bit LS executable, x86-64, version a (SYSV)

I'm new to Linux and UE4 so I might be doing something wrong, but it looks like although I tried to package for Linux ARM, it packaged for x86-64.

Also, wasn't there supposed to be a "*.out" file?

Product Version: UE 4.15
Tags:
more ▼

asked Feb 22 '17 at 12:59 PM in Packaging & Deployment

avatar image

ronir
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey ronir-

In your LinuxNoEditor folder, right click on the ProjectName.sh file and select Properties. In the new window, go to the Permissions tab and set the check box for "Allow executing file as program". Running ./ProjectName.sh from the terminal window should launch the game as expected.

Cheers

Doug Wilson

more ▼

answered Mar 08 '17 at 06:57 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question