Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Failed 4.15

Failed Build log

I'm having trouble packaging my project in 4.15. I'm only working in blueprints and am relatively new to unreal. I also know nothing when it comes to c++ so please no fixes involving that.

I've included my newest build failed log.

Thank you for any help you can give me!

steps I've done so far, trying to package again after each step:

  1. re-saved all of the maps, blueprints

  2. selected only the needed maps to package in the project settings

  3. right-click in the content browser and hit the 'fix up re-directors' option.

  4. Closed the engine, and deleted the Intermediate and Saved.

Product Version: UE 4.15
more ▼

asked Feb 23 '17 at 03:22 AM in Packaging & Deployment

avatar image

254 16 14 23

avatar image DigitalMage Feb 23 '17 at 03:52 AM

Did you get a crash dump? I can check it out for you to see if it's obvious.

avatar image mercuriusfm Feb 23 '17 at 08:51 PM

Hey, I tried googling what a crash dump and I'm still not really sure what it is and where to find it.

avatar image Matthew J Feb 23 '17 at 04:58 PM

Hello mercuriusfm,

It seems that your packaging is failing due to an Ensure. The Ensure is related to the Transform of a SceneComponent and BodyInstance possibly, from looking at the surrounding information. It may be related to your FirstPersonCharacter blueprint.

The first ensure is:

 Error: Ensure condition failed: NewTransform.IsValid() [File:D:\Build\++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\SceneComponent.cpp] [Line: 534]

This is saying that, at this point, NewTransform was not valid when it checked to see if it was or not, meaning any calls to it would result in an access violation.

The second ensure is:

 Error: Ensure condition failed: !NewTransform.ContainsNaN() [File:D:\Build\++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Engine\Private\PhysicsEngine\BodyInstance.cpp] [Line: 3012]

This means that one of the values in NewTransform at this point was NaN (Not a Number) meaning that it's not being populated correctly. I'd check for anything that may be setting the transform of any actors in your project.

avatar image mercuriusfm Feb 23 '17 at 08:51 PM

My game needs the player to be teleported to various spots, so in the blueprints of some of the levels I've transformed the player to specific areas. Does this mean this won't work? or did I do something wrong in the way I came about achieving the teleportation... I just used "set player location" in the blueprints.

I'm not sure exactly what you're telling me to check for, they're all scalar numbers, some are negatives though let me know if that's what your referring to, and if that is an issue.

Also my player first starts at a location in the world that is a very high altitude is that a problem? now that I've been looking at my player start locations I see that one of the the "network player start" says bad size... so I deleted it and tried packaging again... and the packaging failed again...

avatar image mercuriusfm Feb 23 '17 at 08:56 PM
avatar image Matthew J Feb 23 '17 at 09:25 PM

I just realized, from looking at the code around the first ensure, this may be related to this warning that comes up just before it:

 LogSkinnedMeshComp:Warning: GetSocketByName(GripPoint): No SkeletalMesh for Component(Mesh2P) Actor(FirstPersonCharacter_C_1)

The function that comes just before this NewTransform.IsValid() check is setting NewTransform based off of using the new relative transform, the parent, and the socketname. If the socketname is coming up with something null (due to the SkeletalMesh not being set) then NewTransform may end up becoming null, causing the .isValid check to fail.

Can you ensure that Mesh2P has a mesh assigned or remove any socket references related to it?

If this doesn't help, would you be able to provide a copy of your project so that I can run it in debugging to see if I can narrow down what asset is causing the problem? If you need it to be private you can send a link to a download for it to me through a private message on our forums.

avatar image mercuriusfm Feb 23 '17 at 10:18 PM

Now I've deleted the first person character "spawn projectile" bit in the blueprints, since that was the only thing that referred to Mesh2P, and tried to package again.

that didn't work so I just deleted the Mesh 2P , the gun and sphere from the First person character since I don't have a model for my game or any shooting since you don't see the character.

It still failed ensure...

newest fail log

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

As an update,

It wasn't anything in the First Person Character Blueprint, For some reason something I got from the unreal marketplace, ORBIT weather and seasons, was stopping my game from compiling. I've had a few issues with getting ORBIT to work properly.

I just deleted things from my level one at a time until it packaged properly...

Now I have to figure out why its making Ensure fail and what's Transforming to Null Values within it, I have a feeling it's the Moon component but I'm not sure yet.

Thanks for your help.

more ▼

answered Feb 28 '17 at 04:47 AM

avatar image

254 16 14 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question