x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Procedural mesh component doesn't create collision data

Hi,

I just started using ue4 and recently I've been working with the Procedural Mesh Component. Generating a mesh works fine. I'm generating a scalar field from a static mesh and then I triangulate this scalar field with the marching cubes algorithm to produce the same mesh. The generated mesh looks fine except maybe a bit dark.

However, I cannot get the mesh to collide with other objects. It seems to simulate physics, being affected by gravity and responding to AddForce() calls but no collisions. Does anyone have any idea as to what the problem could be? I thought the procedural mesh component would simply generate simple collision if I flagged the collision bool as true when calling "CreateMeshSection(...)".

My mesh generator has two components, the procedural mesh component and a static mesh component. Both are initialized in the constructor. The procedural mesh is then created in BeginPlay() and the static mesh is unregistered and destroyed there as well.

Thankful for any tips or hints, Olle

Product Version: UE 4.15
Tags:
more ▼

asked Feb 23 '17 at 10:16 AM in C++ Programming

avatar image

Bonepower
6 1 2 2

avatar image Bonepower Mar 31 '17 at 03:26 PM

Hey, came back to this problem after more than a month and still cannot figure it out. As far as I understand it the component should be generating collision data but it isn't. It might also be worth mentioning that I'm compiling the engine myself, could this affect it somehow?

avatar image Complex Jun 12 '17 at 08:37 AM

Did you have any luck in fixing this with 4.15 or 4.16? For me both don't work. Posted the same question/problem/bug.
Maybe 4.12 or 13 is just safer

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I have put my ProceduralMeshComponent into its own class, with no scene or actor or whatever on top (its the root component) and it works. yet I have only placed the c++ class into the level and it just starts itself in begin play, but im confident about it

tldr Solution: new actor class with UProceduralMeshComponent.h

more ▼

answered Jun 12 '17 at 02:07 PM

avatar image

Complex
13 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question