x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

In packaged games only, "Is Head Mounted Display" always triggers true

Hello. When I use "Is Head Mounted Display Enabled" in editor or through play, it works perfect.. If in VR mode, it loads my VR stuff, if not in VR preview and the headset is not in use, it loads non VR stuff.

However it functions differently when packaged. I think it's detecting my headset regardless of whether or not I have it on or am using the -vr target parameter to force VR.. and thus it's always loading my VR stuff, even when I want non VR mode. This makes it impossible for me to test non VR without unplugging my HMD, which isn't realistic, and kind of defeats the entire point of the "is Head Mounted Display enabled node"

4.15 (I had this on 4.14 as well) introduced a new node "Is Head Mounted Display Connected" to work alongside "Enabled" which made me think the issue was fixed.. but no. The command properly works in stand-alone mode, it works in all forms of editor play testing.. but when packaged, It always registers as enabled.

I even had my friend make C++ code that checks if the HMD is enabled AND the game is in stereo mode even THAT registers true, even though it's not! Again, works great in editor or stand alone mode.

Product Version: UE 4.15
Tags:
more ▼

asked Feb 24 '17 at 12:12 AM in VR

avatar image

Pinworm
148 13 18 31

avatar image project.gheist Feb 24 '17 at 08:29 AM

Hi Pinworm, can you please list all the VR plugins that you have enabled?

avatar image Pinworm Feb 24 '17 at 08:38 AM

I have no VR plugins enabled except anything that comes by default.

avatar image shriram1026 Dec 08 '18 at 12:27 AM

Hey Pinworm, I'm facing the same issue with the packaged version, I get a side by side output even when the HMD isn't connected (UE4.18, SteamVR, Start in VR - unchecked). Were you able to solve the issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

One idea - There's a project setting (under "Project Settings"->"Project"->"Description") called 'Start in VR' - if that's true, it will always start in VR in a packaged build.

alt text

startinvr.png (5.8 kB)
more ▼

answered Feb 24 '17 at 01:11 AM

avatar image

DigitalMage
401 11 8 25

avatar image Pinworm Feb 24 '17 at 01:18 AM

Thanks for trying, unfortunately it's not checked off for me so that's not the issue :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Disable the Simple HMD Plugin before packaging.

more ▼

answered Dec 10 '18 at 09:38 PM

avatar image

shriram1026
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question