x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Networking session bug(?) empty results with 4.15

Creating/finding sessions seems to be broken in 4.15.0, I have tried everything and I always get a Results length of 0 from find sessions. With the exact same methods, and I have done this about three dozen times this week, it works in 4.14.3 and works in other engine versions. However no matter if I am using NULL or Steam OSS I always get empty results with 4.15.

The only way I get a result is with "Use LAN" set to true on create session, no other sessions make any different. I think the bug might have to do with this 4.15 bugfix

"BugFix: Fixed OSSNull server/session filtering to better match Session Settings and online OSS. Made MCP, Steam, and Null LAN queries more consistent"

Product Version: UE 4.15
Tags:
more ▼

asked Feb 24 '17 at 04:45 AM in Bug Reports

avatar image

JLBXB3
6 1 2 7

avatar image KillerPenguin Feb 24 '17 at 05:25 AM

Got the same problem here....

avatar image nah19 Mar 02 '17 at 01:13 PM

Same issue... Anyone know how to fix it? Even temporary? :(

avatar image J.C. Smith Mar 30 '17 at 02:31 PM

I'm having the same issue and am using 4.15.1

avatar image Sean L ♦♦ STAFF Mar 30 '17 at 02:36 PM

Hey J.C. Smith,

I've verified that the issue is resolved in 4.15.1 using a multiplayer setup through Steam.

I've attached a working project that you can use as a reference:

link text

If you're experiencing an issue connecting with that project (ensure that you have Steam running) it's possible that there is an issue somewhere on your end as well.

steamproject.zip (1.1 MB)
avatar image Nox_A15 Mar 30 '17 at 03:15 PM

Hello Sean,

I'm using "DefaultPlatformService=Null" in DefaultEngine.ini and session search also outputs empty array. I'm not interested in using Steam for testing, so is there any other workaround for this issue? It worked fine in 4.14, now packaged game never finds any session, on single PC nor two PCs (I only need LAN connection, nothing more).

avatar image J.C. Smith Mar 31 '17 at 04:20 AM

Thanks Sean. I'll check this out when I get home today and give an update after I do.

avatar image J.C. Smith Mar 31 '17 at 07:05 AM

Okay I can confirm that they are working in the SteamProject above, even if compiled as shipping and using my own AppID. Will dig in deeper as it must be something on my end.

avatar image Sean L ♦♦ STAFF Mar 30 '17 at 03:47 PM

link text

Hey Nox_A15,

Null also seems to be working according to the project I've set up for testing above. Feel free to download it and take a look at it. C to create a session and J to join a session.

Did you ensure to add:

[OnlineSubsystem] DefaultPlatformService=NULL

to your DefaultEngine.ini?

Also have you ensured to restart the editor if it was open when you added this to the .ini?

nullonline.zip (464.6 kB)
(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hello,

I've reproduced this issue in my test project, and have entered a bug report that you can track using the link below:

https://issues.unrealengine.com/issue/UE-42368

Have a great day

more ▼

answered Feb 24 '17 at 04:06 PM

avatar image

Sean L ♦♦ STAFF
44.2k 485 149 436

avatar image OverRated_AU Mar 21 '17 at 09:06 AM

Sean this issue has been flagged as fixed but i think who every submitted the Bug Report forgot to mention this is mainly a issue with packaged projects, the problem hasn't been resolved in 4.15.1.

avatar image Sean L ♦♦ STAFF Mar 21 '17 at 01:00 PM

Thanks for letting me know. What's the specific case where you are still seeing this issue?

Have you tried disabling Auto Connect to Server under your Play settings in Project Settings to see if that resolves the issue?

If you can provide me with a test project, or a set of repro steps that I can use to reproduce the issue and see that it is still occurring, that would be great.

Thanks

avatar image OverRated_AU Mar 21 '17 at 03:43 PM

Hi Sean, You can reproduce this issue by using the Multiplayer Shootout template and enabling steam online Subsystem, then packaging the project and running two instances one hosting while the other searching for a match, this issue seems to only be when the Steam Subsystem is used, the Null platform seems to work just fine, I couldn't find the setting you described in Project Settings. Thanks

avatar image Sean L ♦♦ STAFF Mar 21 '17 at 05:24 PM

Thanks, I noticed that you have created a new thread in Bug Reports for the issue, so I'm going to go ahead and close that one out and follow up with the investigation here instead. I'll reply here once I have new information.

avatar image OverRated_AU Mar 21 '17 at 05:27 PM

Thanks, and yes i created that before i found this bug report.

avatar image Sean L ♦♦ STAFF Mar 22 '17 at 10:53 AM

I have a question regarding your issue:

Are you testing your packaged project running two instances on the same PC or are you running on two separate PCs?

avatar image OverRated_AU Mar 22 '17 at 11:56 AM

He Sean, I was testing it on the same PC which i was doing on previous builds of the engine, maybe it was defaulting to the Null subsystem before hand? it does seem like it as it worked fine testing on two individual systems, maybe I'm missing something that was change I'm not sure thanks again.

avatar image Sean L ♦♦ STAFF Mar 22 '17 at 11:58 AM

I honestly wouldn't expect two instances of a steam game to work on the same PC, so I'd think that the behavior that you are experiencing is intended. I'm glad to hear that it works fine on two separate systems though. I recommend using that method for further testing.

avatar image OverRated_AU Mar 22 '17 at 01:46 PM

Thanks for the reply Sean yeah i that what i thought but in previous builds it did ether that or it was using the Null system and i didn't know about it ether way thank you for your time.

avatar image Mystra Mar 22 '17 at 08:19 PM

Hi Sean,

You seemed to think that this error was related to the bug I reported at this thread: https://answers.unrealengine.com/questions/568599/multiplayer-blueprint-problems-on-mac-multiplayer.html

However, I can also confirm that my related issue is not fixed with 4.15.1. In particular, I cannot form any connection between two instances of a packaged game on Mac, even on a LAN.

avatar image Sean L ♦♦ STAFF Mar 23 '17 at 01:24 PM

Hey Mystra,

Yeah that issue has been resolved. I suspected it was related but it seems that it could be something different. I'll be investigating and I'll respond over on your thread when I have new information.

Thanks

avatar image quimnuss Jan 28 '18 at 09:25 PM

I'm having the same problem on 4.18. Am I alone? Neither nullproject nor steamproject succeed finding a session. Nullproject multiplayer works on the same PC. I'm with two steam accounts on two PCs on the same LAN. The steam overlay works. Find sessions always returns an empty array. Looking at the logs, there are maps listed but none match what (I guess) steam is expecting.

avatar image Jason77 Mar 19 '18 at 08:50 AM

I trying on Multiplayer shootout project on 4.18, and this issue is still exist (Using Lan connection).

avatar image quimnuss Apr 08 '18 at 04:25 PM

Am I the only person worried about this? Seems like a critical issue to me...

(comments are locked)
10|2000 characters needed characters left

Thank you Sean for this test project. It helped me to find an issue in one minute and solution in my case was so easy, that it's a bit embarrassing to admit. :) I needed to set Public Connections in Create Session node to something more than 0. Seriously, I have no idea why it changed back to 0 with engine version transition. Thanks again!

more ▼

answered Mar 31 '17 at 09:02 AM

avatar image

Nox_A15
284 16 135 191

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question