x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Asset migration breaks LOD screen sizes, bug report

Hello,

I've just converted a project from 4.14 to 4.15. Kite assets couldn't be converted so i re-download new version of it and replaced on project. But now the problem is my fps dropped from ~90 to ~10. Everything "Dynamic" on gpu profiler takes around 20-25 ms, DBuffer also. I almost checked everything, reset settings of the rendering from project settings. Disabled DBuffer but still "Dynamic" eats a lot of performance. Even though i delete directional light (only light in the scene), "Dynamic" still eats 20ms. Scene uses kite demo assets.

I'm attaching an image to show difference and gpu visualizer screenshot. I hope someone can help me about this problem.

alt text

I found the reason with the help of someone from discord channel. He says migration can break the lod screen sizes of static meshes. At first i migrated all 4.14 assets to 4.15. But later i downloaded 4.15 kite demo assets and replaced them on the project. But LOD screen size of all static meshes is 0. Triangle count is like 6x of original scene. It should be a bug.

Product Version: UE 4.15
Tags:
more ▼

asked Feb 24 '17 at 06:17 AM in Bug Reports

avatar image

theknoppix
84 10 14 20

avatar image jonimake Feb 24 '17 at 06:50 AM

I have had the same problem with my migrated project. Can't remember if it was in place or a copy.

avatar image theknoppix Feb 24 '17 at 08:02 AM

Also lod materials come set as WorldGridMaterial. Even though i set proper material, it reverts back on save to WorldGridMaterial.

http://prntscr.com/ecq9jw

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi guys,

If you look at the 4.15 release notes you will find a bullet point listing this "LOD for Foliage and Hierarchical Instanced Static Mesh Components is now consistent with regular Static Meshes and uses a new screen size calculation."

My guess is that the new screen size calculation is altering the settings you specify when migrating to a new engine version. My other guess is that our samples team simply migrated the kite demo to 4.15 and is suffering from the same problem I'll double check this and let them know if they need to update the samples content.

Unfortunately, things like this are a risk you run when migrating to a new engine version.

Regarding your LOD material problem if you look at your slot name for element 3 and 4 they have the same slot name. I know from experience that having two elements share a slot name can cause errors like the material not saving or mimicking the other element's material.

Let me know if that helps!

more ▼

answered Mar 03 '17 at 04:02 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I checked release notes again and noticed that change. I didn't know slot names can be same so most likely, issue reason is that. I thought at least kite demo 4.15 assets should work like intended. At the moment i continue to work on 4.14 but i'll fix them myself when i upgrade my project to 4.15.

Thanks for the information.

more ▼

answered Mar 06 '17 at 08:12 AM

avatar image

theknoppix
84 10 14 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question