x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android for Distribution - Packaging Fails - FileNotFound

Hey, I've been trying to get an Android apk ready to distribute, but every time I set the 'For Distribution' option to true the packaging fails. Packaging Development or Shipping with for distribution set to false works fine.

The only error I can see in the log is a FileNotFoundException for "[PROJECT PATH]\Intermediate/Android/APK/bin/[PROJECT NAME]-release.apk".

Log file here

I've looked around and though many people have had a similar issue, I haven't found a solution that works for me.

Some notes:

  • I've tried packing with Codeworks 1R5 and 1R4u2 and set SDK folder locations in the Project Settings each time

  • I'm using Google VR for Cardboard functionality

  • I generated a keystore file that matches with information input in Project Settings, it's currently located in ProjectFolder > Build > Android

Am I missing something?

Product Version: UE 4.14
Tags:
uat_log.txt (977.1 kB)
more ▼

asked Feb 24 '17 at 06:23 AM in Packaging & Deployment

avatar image

CaptParis000
41 1 6 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found the answer here:

https://answers.unrealengine.com/questions/505397/trouble-packaging-google-vr-project-for-android-fo.html

Turns out it was a problem with packaging for distribution with GoogleVR. It's important to ensure you download the newest version of proguard and replace as shown in this video: https://www.youtube.com/watch?v=kF2SkkNA4Cs

It's definitely very finicky, I'm hoping moving over to 4.15 will improve things.

more ▼

answered Mar 01 '17 at 12:38 AM

avatar image

CaptParis000
41 1 6 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey man to recheck the distribution settings. Try packaging without for-distribution checkbox. If the packaging succeeds, the problem lies with the distribution settings. Check out my answer in this post for the above reason.

link text

Make sure your SDK is correctly set up.

more ▼

answered Feb 27 '17 at 03:20 AM

avatar image

SHOBBIT
650 13 13 28

avatar image CaptParis000 Feb 27 '17 at 04:27 AM

Hey Shobhitthackar, thanks for the response! The issue only occurs when 'For Distribution' is ticked. However, I've rechecked and recreated keys a number of times with no luck. All the information in Project Settings matches the keystore name, alias and passwords.

I actually just managed to create a package with for distribution and installed on phone successfully a few times with a blank project. I then turned on 'Google VR' plugin and tried to repackage and I get this error again. Even after I disable the plugin it remains unable to package; somehow it causes a permanent problem with the project.

Have you tried using Google VR at all?

avatar image SHOBBIT Feb 27 '17 at 05:46 PM

No, I haven't done any VR stuff yet. So sadly this is where my helpline ends :D. Sorry, hope you find a resolution asap.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question