x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Profile GPU - Bass pass

My game has some frame issues and I've been checking GPU.

alt text

As you see, static EbasePassDrawListType = 0 is the NO.1 contributor of frame time! :) I've been checking c++ source code and found out that static EbasePassDrawListType = 0 indicates that static mesh basspass type is basspass default. My question is what exactly this is telling me in GPU Visualizer? Is it just telling me that the drawing of static meshs makes the FPS worse? How do I optimize this?

Product Version: UE 4.14
Tags:
profilegpu.png (65.1 kB)
more ▼

asked Feb 24 '17 at 08:58 AM in Using UE4

avatar image

SuKim
41 2 4 6

avatar image Mcfn Feng Feb 28 '17 at 11:52 AM

I also have the same issue when play media(movie).

avatar image Jake1337 Mar 06 '17 at 11:14 PM

Same question here, would love for some one to shed some light on this issue.

avatar image Hyperion 5 Mar 13 '17 at 04:51 PM

Same issue i have. And dont know how to fix or optimize this :(

I have many simple objects with texture: Info Base pass shader with static lighting: 74 instructions Info Base pass shader with only dynamic lighting: 47 instructions Info Vertex shader: 31 instructions

When i look at this objects with different angles i see different Fps, for example: Maximum - 230 fps Minimum - 200 fps These 30 fps are taken away by the BasePass (static EbasePassDrawListType = 0 )

When I change r.EarlyZPass and r.EarlyZPassMovable i see same result. Only the angle at which different Fps are displayed changes.

alt text

alt text

avatar image Hyperion 5 Mar 14 '17 at 12:53 AM

If anyone is interested, my problem was resolved by setting parameters to these values: r.EarlyZPass 1 (also 2 sometimes) r.EarlyZPassMovable 1 (default is off) It works only together!

Now FPS is more stable, especially on a laptop.

P.s. On a stationary computer, the problem was also solved by this command r.AmbientOcclusionMaxQuality 0 (or more maybe), but it certainly spoils the graphics quality unlike those commands (ZPass)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Base Pass is responsible for many things - all related to preparing data for next passes after it. So:

  • Running the materials and saving their output (color, roughness, metallic etc.) to the GBuffer

  • Applying DBuffer decals (so watch out if you have a lot of these)

  • Reading lightmaps

  • some other small tasks, like fog

Either you have a big number of objects, heavy shaders or many decals. And it's all "multiplied" by the game resolution.

I explain it in detail in my video at 22:50: https://www.youtube.com/watch?v=C3lumWdwHmA Hope it helps.

edit: Early Z-Pass probably helped because it allows to discard occluded areas before the Base pass. It has a cost of it's own, but here I can see it was worth it.

Regards,

Oskar

more ▼

answered May 15 '17 at 03:38 PM

avatar image

Oskar Świerad
378 13 28 28

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question