x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How can I precisely scale collision capsules?

When I try placing collision volumes for a static mesh asset, it's impossible to get them exactly right because I can't scale them smoothly, nor can I enter values manually. Even with snapping turned off and only the slightest mouse movement, the scale is jumping all over the place:

UE4 Scaling Issue

Is there anything am doing wrong or any settings I can change to make this process easier?

Thanks in advance.

Product Version: UE 4.15
Tags:
more ▼

asked Feb 24 '17 at 12:46 PM in Using UE4

avatar image

Efrye
266 20 30 37

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Are you sure you're turning the correct snap? Each transform has its own transform snap option to toggle. The Scale is the one on the right.

alt text

I've had problemas with the scale of capsules once when I had to deal with a small capsule, the scale control was just off for some reason, but that's why I prefer to go into the Details tab and tinker with the Capsule settings. alt text

These settings have sliders so you can change them smoothly. Hope that helps!

more ▼

answered Feb 24 '17 at 01:03 PM

avatar image

Luiz Sotero
115 1 7 9

avatar image Efrye Feb 24 '17 at 01:29 PM

Thanks for your reply.

Snapping is definitely disabled. I also tried setting the scale snapping to the lowest possible value (0.03125), but that didn't help either.

I would be perfectly fine with using the "Capsule Half Height" and "Capsule Radius" values, but I can't access them in the static mesh view. The details panel only displays settings for the mesh itself and doesn't update when I select a collision volume.

avatar image Luiz Sotero Mar 06 '17 at 12:26 PM

Did you manage to get it to work?

avatar image Efrye Mar 06 '17 at 01:30 PM

No, unfortunately this is still an issue. It appears to be a little smoother in 4.15, but I still cannot scale the collision capsules in the static mesh editor to the exact size I need.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Checking "Use Percentage Based Scaling" in Editor Preferences fixes the coarse snapping that happens in the static mesh collision editor even when scale snapping is disabled.

Thanks to Wallenstein at https://answers.unrealengine.com/questions/830473/mouse-sensitivity-when-scaling-collision-boxes.html for pointing this out :)

more ▼

answered Aug 12 '19 at 08:42 PM

avatar image

ericwa
66 1 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question