x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Google Play, 2500 devices removed, 7 left.

Upgraded 4.14.3 to 4.15.0, compiled my app with same parameters, and uploaded to Google Play.

The Dashboard, removed 2499 visible devices from the App, and made it available only to 7 !

There is any logic explanations to this?

I didn't change anything on Android settings from the two versions.

The app has Google VR enabled, and Daydream + Cardboard mode actived.

alt text

Product Version: UE 4.15
Tags:
capture.jpg (42.5 kB)
more ▼

asked Feb 24 '17 at 01:39 PM in Packaging & Deployment

avatar image

jined
16 3 3

avatar image Samantha Sutton ♦♦ STAFF Feb 24 '17 at 06:12 PM

Jined,

Since you have Daydream activated in the project settings, 7 devices are all that would be supported. There are only 7 devices currently that support Daydream so is likely the reason you're seeing this. However, please upload your AndroidManifest.XML with your next reply too. It should be in your Intermediate folder once you've packaged.

Thanks!

avatar image jined Feb 25 '17 at 11:20 AM

Yes, but the settings have both Cardboard + Daydream.

I noticed if i remove the Daydream setting, the devices get back to over 2500, but if i use Daydream only or Daydream + Cardboard, the device visibility gets to 7 devices only,

Adding Daydream + cardboard, visibility should be 7 + 2500 right?

link text

avatar image Samantha Sutton ♦♦ STAFF Feb 28 '17 at 11:12 PM

Because you included Daydream, it lowered the amount of devices down to 7. I will pass your manifest along to our Android Developer though, to see if there is something that I may have missed.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It's possible that the android.hardware.high_performance setting required to be 'true' which is restricting it to Daydream devices only. Have you tried changing that to false and seeing the results?

Looking forward to hearing back from you, thanks!

more ▼

answered Mar 06 '17 at 05:57 PM

avatar image jined Mar 24 '17 at 04:02 PM

I did this change, the device list increased to about 200 devices.. quite far from the over 2500 supported.

avatar image jined Mar 24 '17 at 05:09 PM

i find out the problem, it is the "android.software.vr.mode" setting, putting to false, will raise the devices back to 2500.. but the question is... the app will still be Daydream compliant?

avatar image Samantha Sutton ♦♦ STAFF Mar 24 '17 at 06:52 PM

I've entered UE-43314 for this issue.

avatar image Chris Babcock STAFF Mar 28 '17 at 09:51 PM

Daydream and Cardboard option should not set either android.hardware.vr.high_performance or android.software.vr.mode to required="true". I've made the fix for 4.16, but since it is just a text file you can make it to your copy. Edit Engine/Plugins/Runtime/GoogleVR/GoogleVRHMD/Source/SoogleVRHMD/GoogleVRHMD_APL.xml and change:

         <if condition="bSupportDaydream">
             <true>
                 <addFeature android:name="android.hardware.vr.high_performance" android:required="true" />
                 <addFeature android:name="android.software.vr.mode" android:required="true" />
             </true>
             <false>
                 <addFeature android:name="android.hardware.vr.high_performance" android:required="false" />
                 <addFeature android:name="android.software.vr.mode" android:required="false" />
             </false>
         </if>
 

to

         <if condition="bSupportDaydream">
             <true>
                 <if condition="bDaydreamAndCardboardMode">
                     <true>
                         <addFeature android:name="android.hardware.vr.high_performance" android:required="false" />
                         <addFeature android:name="android.software.vr.mode" android:required="false" />
                     </true>
                     <false>
                         <addFeature android:name="android.hardware.vr.high_performance" android:required="true" />
                         <addFeature android:name="android.software.vr.mode" android:required="true" />
                     </false>
                 </if>
             </true>
             <false>
                 <addFeature android:name="android.hardware.vr.high_performance" android:required="false" />
                 <addFeature android:name="android.software.vr.mode" android:required="false" />
             </false>
         </if>
 
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question