x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

When i try to test my Gear VR build, it just opens the oculus store

I have a Samsung Galaxy S7, i was able to successfully package and install the game on my Galaxy s7 without any errors. When i try to run the game, it tells me to insert the phone into the GearVR (as it should). When I plug the phone in, the screen is just black for a few seconds and then it opens to oculus store. Ive seen a few posts from people a few months ago with the exact same issue, and they didnt get resolved. Id also like to point out that i have tested games form gamemaker and Unreal on this phone before no problem, but gear vr apps seem to really want to open the store. Does anybody know how i can actually test my Game??

Product Version: UE 4.15
Tags:
more ▼

asked Feb 25 '17 at 08:52 PM in VR

avatar image

ViceVersa
1k 62 45 94

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Are you absolutely sure you followed all the steps correctly? Did you put the OSIG file in both the Engine's program files folder, and on your phone? This typically happens if you don't do the OSIG correctly. It just aborts the game and dumps you in the Oculus Store, because it's just reading as an unauthorized game with no developer privileges.

more ▼

answered Feb 27 '17 at 03:20 PM

avatar image

GrayGhostOne
60 1 6 9

avatar image ViceVersa Feb 28 '17 at 02:39 AM

Okay so you were correct about the osig file, i missed that step. Its in the correct folder on my computer, where exactly do i put it on the phone i didnt see that step anywhere?

avatar image GrayGhostOne Feb 28 '17 at 08:16 AM

I put mine in the root directory of the phone's storage and it works fine. What I mean by that specifically is when you plug your phone into your PC and can access the phone's internal (and optional SD card) storage, just drop it in that root directory of the internal storage, and you should be fine.

avatar image xN31 Feb 28 '17 at 08:25 AM

You should create an "assets" folder and copy the osig files for the devices you want to enable in the UE4 installation. When building the app, the UE4 editor will automatically copy the files to the device.

On mac, for example, the folder would be:

/Users/Shared/Epic\ Games/UE_4.15/Engine/Build/Android/Java/assets

avatar image ViceVersa Mar 04 '17 at 12:59 AM

I am marking this as resolved as the original problem has been fixed. I needed to generate the osig file, put it in the folder xN31 described above, and in the root directory of the phone as GrayGhostOne said. I am having a new problem though, After installing it if my phone is in the Gear VR developer mode, when i try to test the app the screen goes black for 3 seconds and then returns to my home screen. Any ideas why that may be happening?

avatar image GrayGhostOne Mar 05 '17 at 09:23 AM

Did you check the logcat? There are two ways to do it, but the easiest way (provided it works) is to go into Editor Settings->General->Experimental and check the "Device Output" tickbox. If that doesn't work, you'll have to do it via the command line/PowerShell (or Terminal if you're in Linux), and run the logcat command.

Your logcat, or device output will give some clues as to what the problem is. Are you trying to use Vulkan or ES3.1? I still haven't been able to get either one working on my Galaxy S7, so if either of those are enabled, try disabling those.

avatar image ViceVersa Mar 11 '17 at 04:01 AM

Neither is enabled.. And i just tried it with a brand new project from scratch and the exact same thing is happening.

(comments are locked)
10|2000 characters needed characters left

Try checking the logs of the device with adb. The issue il likely related to the osig file, as GrayGhostOne suggested, and you should be able to find an error message related to entitlement verification if this is the case.

more ▼

answered Feb 27 '17 at 05:02 PM

avatar image

xN31
66 2 7 9

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question