x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Have to regenerate intermediate after every failed compile

I'm having an odd problem, and I'm not sure how to get to the bottom of it. I have a project I made in UE4.15. It's a pretty small project consisting of just a few scene components and an actor, but every time I try to compile it and the compile fails, I get the waitmutex 5 error. If I fix the compiler error, I will continue to get the waitmutex 5 error. The solution to this is to destroy the intermediate and regenerate the solution and compile again with success.

Has anybody encountered anything like this before? What troubleshooting steps should I take?

Here is an example of compile output for a failed compile:

 1>------ Build started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
 2>------ Build started: Project: UserAnalysisToolkit, Configuration: Development_Editor x64 ------
 2>  Compiling game modules for hot reload
 2>  Performing 3 actions (4 in parallel)
 2>  UserViewAnalyser.cpp
 2>  [2/3] Link UE4Editor-UserAnalysisToolkit-8307.dll
 2>  [3/3] Link UE4Editor-UserAnalysisToolkit-2424.lib
 2>     Creating library C:\Users\calem\Documents\Unreal Projects\UserAnalysisToolkit\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-UserAnalysisToolkit-8307.lib and object C:\Users\calem\Documents\Unreal Projects\UserAnalysisToolkit\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-UserAnalysisToolkit-8307.exp
 2>     Creating library C:\Users\calem\Documents\Unreal Projects\UserAnalysisToolkit\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-UserAnalysisToolkit-8307.suppressed.lib and object C:\Users\calem\Documents\Unreal Projects\UserAnalysisToolkit\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-UserAnalysisToolkit-8307.suppressed.exp
 2>ERROR : UBT error : Failed to produce item: C:\Users\calem\Documents\Unreal Projects\UserAnalysisToolkit\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-UserAnalysisToolkit-2424.lib
 2>  Total build time: 4.88 seconds (Local executor: 0.00 seconds)
 2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3075: The command ""C:\Program Files\Epic Games\UE_4.15\Engine\Build\BatchFiles\Build.bat" UserAnalysisToolkitEditor Win64 Development "C:\Users\calem\Documents\Unreal Projects\UserAnalysisToolkit\UserAnalysisToolkit.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.
 ========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Product Version: UE 4.15
Tags:
more ▼

asked Feb 26 '17 at 02:11 PM in C++ Programming

avatar image

calembendell
447 35 37 67

avatar image DigitalMage Feb 26 '17 at 03:03 PM

Tagging. We've had lots of problems with hot-reload in 4.15. It worked fine in 4.14, but something is locking the game DLLS in 4.15.

We've switched to just exiting unreal, compiling, and rerunning, but this is a considerable nuisance over how nice it worked in 4.14.

avatar image calembendell Feb 27 '17 at 03:14 AM

I ended up just switching back to UE4.14. Fortunately I haven't integrated any 4.15 features into my projects. Giving full permissions to the game DLLs from command line doesn't even seem to fix the problem, so I'm a little lost! :D

I'm glad someone else is having the problem. Sorry for your inconvenience, but maybe it'll get fixed soon!

avatar image bstone Feb 28 '17 at 06:56 AM

You didn't have to switch to 4.14. Hot reloading works it's just that UBT fools itself by loosing tack of build numbers. You can simply ignore that specific UBT error until it's fixed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question