x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Gear VR 4.15] Widget Interaction Tool "Show Debug" Shows nothing

This is really weird. At the very beginning of my game, the player is sitting in front of the main menu, and I'm using a 3D Widget for this menu. They select options using the widget interaction tool, and to help them see what button they're pointing at, I enable the "show debug" option on the WIT, using the standard red color. This has been working fine for months on 4.10-4.14. I recently tried out 4.15 and started a blank project, and tried to use the same settings on the WIT, and while it renders fine on my PC when I play in PIE or using the Android standalone, it doesn't render at all while in-game on the actual phone (Galaxy S7 non-edge, running Nougat 7.0). I even tried running through all the settings in blueprints during run-time to make sure it was on, and everything checks out (meaning, the game is reporting that the WIT is in debug mode and rendering correctly), but it's not visible at all.

The WIT is functionally working just fine. Buttons still hover and click exactly as they should, it's just not showing the red debug ray. Anyone else have this problem, or know of any solutions? Does the WIT rely on something graphically that I may have disabled, like translucency, shadows, Bloom, HDR, etc? It worked fine in older iterations of my current project, which I'm 99% sure I had nearly all the pretty graphics settings turned off or way down, and it worked fine, so I got nothing.

Thanks!

Product Version: UE 4.15
Tags:
more ▼

asked Feb 27 '17 at 03:11 PM in VR

avatar image

GrayGhostOne
60 1 7 9

avatar image GrayGhostOne Mar 03 '17 at 01:38 PM

I just tested this in 4.14, and it seems to be doing it in 4.14 as well, even though as I mentioned in OP, it was working fine just a couple of weeks ago. Unfortunately, I only have one Galaxy S7 to test this on, so I can't say if it's a problem with my phone or if there was some engine update that broke this, but it's a pretty significant problem for our game, and we can't publish it until this gets fixed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you exporting with "For Distribution" ticked? Then you don't see this debug trace/line

more ▼

answered Apr 16 '17 at 01:10 PM

avatar image

aussieburger
1.5k 43 176 75

avatar image GrayGhostOne Apr 16 '17 at 04:52 PM

I don't think I was, but I didn't realize it did that. So if I'm relying on this for users to interact with the menu, you're saying that won't work? We can't use any of the debug features in our final release? If that's the case, how can I make something like the debug laser pointer that will work in the release version?

avatar image aussieburger Apr 16 '17 at 05:42 PM

Yeah there is a workaround without modifying the engine source code if you export without distribution (as I wanted that line as well): extract the manifest from the apk using apktool then change debugable to false in both locations then rebuild the apk and then sign and zip align the apk manually

avatar image GrayGhostOne Apr 16 '17 at 06:59 PM

Oh, Jesus. I've never done that before, so maybe it's easier than it sounds, but it sounds about as difficult as having my art guy make a custom asset that looks like the laser pointer and use that instead. Thanks for the heads up, aussieburger!

avatar image GrayGhostOne Apr 27 '17 at 03:10 AM

Thanks, AussieBurger, I looked into it, and it turns out it was much easier than it sounded (this is my first attempt at an Android game, and I'm not terribly familiar with the Android tools). I have one question though, if you don't mind. You mentioned signing the app in your reply. Does it need to be signed if it's a GearVR app? I thought you only needed to sign it if it was going up on the Play Store? Thanks :)

avatar image aussieburger Apr 27 '17 at 07:56 AM

yes it needs to be signed for the Oculus platform as well.

You create a keystore file like so:

keytool -genkey -v -keystore mykeystore.keystore -alias alias_name -keyalg RSA -keysize 2048 -validity 10000

then can easily sign with it like so:

jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore mykeystore.keystore myproject.apk alias_name

then zip align so like so:

zipalign -f -v 4 myproject.apk myproject-zipaligned.apk

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question