x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

A.R.T. Tool can't build Character

Hey, I am using the A.R.T. Tool in Maya to Build a Character for Unreal. The Problem is, that it can not build the character. When building process is running, it stops at 20% (and still stay there) and I get an error output:

  • Error: RuntimeError: file G:/UE4/Epic Games/MayaTools/General/Scripts/art_v1\ART_skeletonBuilder_UI.py line 7187: setAttr: The attribute 'root.translateX' is locked or connected and cannot be modified.

Im using Maya 2017. Have anyone any idea, what to do? Another problem here (maybe because of the same error) is that it changes my Character. I can see the builded character in the viewport but one arm is.... just look:alt text

But as I mentioned before, it could be because of the not finished building process.

Thanks for help^^

Product Version: UE 4.15
Tags:
a.r.t. bug.png (89.9 kB)
more ▼

asked Mar 03 '17 at 12:56 PM in Everything Else

avatar image

Niagarer
1 3 2 4

avatar image Niagarer Mar 04 '17 at 04:08 PM

UPDATE:

Ok, today the building process worked (still Maya 2017), but when its finished, the caracter is completely destroyed, like that: alt text

Then I thought, ok, all guys in the tutorial are using Maya 2014, so why not. I tried. Building Process finished, Same Mesh-Destruction (see pic) :/

Don't know what to do next, I just want to get my character for Unreal :D

Here are all my settings I took for the character:

alt text

avatar image Niagarer Mar 05 '17 at 05:49 PM

UPDATE:

Ok, now I know, that A.R.T. has a problem with the poses. The Rig Pose and the Model Pose as well are not working right! If I do nothing, my character isnt doing anything wrong. But if I clock on Assume Model Pose OR Assume Rig Pose (same result), the character is stretched out, the Fingers are rotated, the head is set down, the legs are rotated and bent ... in a nunshell: it looks like in the last update above. And yes, after building process, I get exactely this destroyed mesh:

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question