x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] Actor takes up resources after DESTROYED

Hi guys,

I don't know if anyone else has seen this issue, I try to describe it as much as possible.

  1. blueprint containing animated mesh is spawned (running character)

  2. after the animation routine is finished the actor is DESTROYED

The characters spawn on regular basis few times per minute, however after a short while (1 minute or so) the game starts to slow down to a point when it is absolutely unplayable.

Even when I add on Begin play some delay and then calling destroy actor (self) , the issue still persists.

Is this a core engine bug ? or is there any other way to totaly remove / destroy the actor ?

Product Version: UE 4.15
Tags:
more ▼

asked Mar 03 '17 at 02:53 PM in Bug Reports

avatar image

DExUS5
47 4 7 11

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

I've tested this, but in my project the actor is being destroyed successfully and not leaving behind any traces that are taking up resources.

Could you please provide screenshots of your relevant blueprints?

Are you able to reproduce the issue in a clean project? If so, please provide a detailed list of repro steps.

Thanks

more ▼

answered Mar 03 '17 at 04:23 PM

avatar image

Sean L ♦♦ STAFF
44k 485 149 438

avatar image DExUS5 Mar 03 '17 at 05:50 PM

Hi,

I just tried it on empty project (transfered the BP's directly) , works fine there... It seems I have to remove features from the character untill I get to the point.

avatar image Sean L ♦♦ STAFF Mar 06 '17 at 02:58 PM

Sounds good, feel free to reopen this thread with a comment if you are able to reproduce the issue in a clean project and determine the cause of the issue and we can continue to investigate.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question