x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My java version is unnable to support android-24 API, even after I updated it

I'm trying to package a project for Google VR on UE4.15, and the versions requested of the android sdk are 24 or 25. I already tried to unninstal all AndroidWorks, all SDK's, NDK's and java, to reinstall all again with all the latest versions of each, but even after that, the same error appear on my packaging project:

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\common_library\libs\protobuf-javanano-3.0.0-alpha-7.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\support-v4-23.0.0\libs\support-v4-23.0.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-auth-base-9.2.0\libs\play-services-auth-base-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-gass-9.2.0\libs\play-services-gass-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-tasks-9.2.0\libs\play-services-tasks-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-drive-9.2.0\libs\play-services-drive-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-ads-9.2.0\libs\play-services-ads-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-ads-lite-9.2.0\libs\play-services-ads-lite-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading program jar [C:\Users\User\Documents\Unreal Projects\CyberGunVR 4.15\Intermediate\Android\APK\JavaLibs\play-services-auth-9.2.0\libs\play-services-auth-9.2.0.jar]

UATHelper: Packaging (Android (All)): [proguard] Reading library jar [C:\Program Files (x86)\Android\android-sdk\platforms\android-24\android.jar]

UATHelper: Packaging (Android (All)): BUILD FAILED

UATHelper: Packaging (Android (All)): C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:871: Can't read [C:\Program Files (x86)\Android\android-sdk\platforms\android-24\android.jar] (Can't process class [dalvik/annotation/TestTargetClass.class] (Unsupported class version number [52.0] (maximum 51.0, Java 1.7))) UATHelper: Packaging (Android (All)): at proguard.ant.ProGuardTask.execute(ProGuardTask.java:315)

I'm pretty sure that all the paths to these files requested are right, so i'm pretty lost about what to do. I think that Unreal is using Java 1.7, even after i had updated it to 1.8_121, and that's why my package process always fails... Can someone give me a hand with this?

Product Version: UE 4.15
Tags:
more ▼

asked Mar 04 '17 at 03:52 AM in Packaging & Deployment

avatar image

kska
1 1 2 3

avatar image Samantha Sutton ♦♦ STAFF Mar 06 '17 at 08:38 PM

kska,

Could you please upload a screenshot of your Android SDK? Are you able to package using Android-24? Android-25 isn't supported:

 UATHelper: Packaging (Android (ETC2)): Error: Target id 'android-25' is not valid. Use 'android.bat list targets' to get the target ids.
 UATHelper: Packaging (Android (ETC2)): UEDeployAndroid.RunCommandLineProgramWithException: Updating project.properties, local.properties, and build.xml for support-v4-23.0.0..
avatar image kska Mar 06 '17 at 10:54 PM

Yeah Samantha, I'm using Android SDK and NDK 24, now that i've updated my proguard, everything is working - thanks

(PS: I'M A BIG FAN OF YOURS -)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try updating your proguard version it's what I needed to do. Seems to be needed for android sdk 24 as the packaged version with UE4 does not support java 8 afaik.

https://sourceforge.net/projects/proguard/files/

more ▼

answered Mar 04 '17 at 07:59 AM

avatar image

aussieburger
1.5k 43 176 75

avatar image kska Mar 04 '17 at 06:48 PM

Thank you so much! - Worked haha. But now I got a new problem :( My app, launched on my phone with 150mb, now have 1.12gb packaged :( Do you know how to solve this? :(

avatar image aussieburger Mar 05 '17 at 10:25 AM

Package for Android ETC2 and tick "create compressed package" in the advanced package settings to get your filesize down

avatar image kska Mar 06 '17 at 01:52 AM

It's already ticked :/

avatar image aussieburger Mar 06 '17 at 12:26 PM

And which Android texture do you export for? ETC2 or something else?

avatar image kska Mar 06 '17 at 10:58 PM

In fact, I was looking at my content folder, and when i updated my project by UE4.14 to UE4.15, the starter content had been restored .-. Sorry kk everything is working now! Thank you so much dude! You are foda! (this is a great quality here in Brazil)

avatar image aussieburger Mar 07 '17 at 12:27 PM

don't forget to accept the answer then ;)

avatar image fikriemre Apr 23 '17 at 05:34 PM

Wow thank you sir u save my day

avatar image w0lfi Jul 01 '17 at 08:48 PM

Thank you so much! You saved my day too. :)

avatar image JakobR Dec 07 '17 at 08:34 PM

Wow updating the proguard in C:\NVPACK\android-sdk-windows\tools actually worked for 4.15 ! This is amazing! It got rid of the

BUILD FAILED UATHelper: Packaging (Android (ASTC)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:871: Can't read [C:\NVPACK\android-sdk-windows\platforms\android-27\android.jar] (Can't process class [android/R$xml.class] (Unsupported class version number [52.0] (maximum 51.0, Java 1.7)))

Thanks so much.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question