x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to disable "Fast Path"?

alt text

Hello, I was working on a project and encountered a problem, so I was doing a small test. The screen shot is from that. The problem is that "Fast path is enabled" on animation bp. I checked: https://docs.unrealengine.com/latest/INT/Engine/Animation/Optimization/FastPath/ but I am not proficient enough to understand the document. It seems not many people asking same question. https://www.youtube.com/watch?v=wr68qYYtmq8&list=PLZlv_N0_O1gb5sdygbSiEU7hb0eomNLdq∈dex=18 There are few, but I don't get the answer either....

Thank you in advance!

Product Version: UE 4.13
Tags:
fastpathenabled.jpg (621.1 kB)
more ▼

asked Mar 05 '17 at 07:18 AM in Using UE4

avatar image

octypants
6 1 1 1

avatar image Caysekong Oct 16 '17 at 09:23 PM

Ever get an answer to this?

avatar image tongucci Jan 26 '18 at 01:50 PM

I am having the same issue. Can somebody help, please?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

FastPath is good. It basically means your animation blueprint will run faster than normal, by using multithreading. You don't need to worry about the specifics if you do not care about performance at the moment.

A quick summary is basically this: If one node in the ABP does not support fast path, your whole blueprint will be slower. It is automatically disabled if any node does not fulfill the requirements. If you want to make sure you have fast path fully enabled, try to pre-calculate all necessary variables in the event graph (or in code) and use only raw floats and bools in the animation blueprint.

more ▼

answered Jan 29 '18 at 03:04 PM

avatar image

emanuel.may
54 1 3 7

avatar image tongucci Jan 29 '18 at 03:22 PM

Thank you for the answer. My enemy character didn't switch to run animation from walk when his max walk speed was switching from 150 to 600. I thought FastPath was causing that. Then in ABP's Event Graph I set the speed variable from the character's max walk speed instead of velocity, and it worked for me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question