Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Install/Compile Engine from source with VS 2017


I downloaded the release version of the Engine (4.15) and wanted to compile it from source. Before this I was using the pre-compiled 4.13 version so it's my first attempt at compiling the engine.

I have Visual Studio 2017 on Windows 10 and I have incurred in the following error when trying to run "GenerateProjectFiles.bat" after running Setup.bat:

C:\Users\Francesco\Documents\UnrealEngine-release>GenerateProjectFiles.bat -2017 -CurrentPlatform -NoShippingConfigs

Setting up Unreal Engine 4 project files...

C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1098,5): error MSB3644: The reference a ssemblies for framework ".NETFramework,Version=v4.5" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Ta rgeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend. [C:\ Users\Francesco\Documents\UnrealEngine-release\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.csproj]

GenerateProjectFiles ERROR: UnrealBuildTool failed to compile

(pasted from command line window)

I have installed the older Visual C++ Build Tools 2015 from http://landinghub.visualstudio.com/v...pp-build-tools and have both the VC++ 2017 v141 toolset (x86,x64) and the Visual Studio C++ core features,

I have also installed the Windows SDK 8.1, and have .NET Framework 4.5 and .NET Framework 4.6.2 SDK installed on my system (https://www.microsoft.com/net/download/framework)

I tried to open the UnrealBuildTool.csproj and to select a different version of the .NETframework target when prompted, but even so I get the same error as above when trying to launch GenerateProjectFiles.bat (regardless of whether I add "-2017 -CurrentPlatform -NoShippingConfigs" or not.)


Product Version: UE 4.15
more ▼

asked Mar 05 '17 at 05:25 PM in Installation & Setup

avatar image

11 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi agapesoft,

Sorry for the delayed response. If you are still having trouble with this, try running the Visual Studio Installer and select the option to Modify your Visual Studio 2017 installation. In there, make sure the option for .NET desktop development is selected:

.Net desktop development

If it is not selected, you may need to uninstall your existing .NET framework installation first. In my case, this was not selected since I had the frameworks installed already for previous versions of Visual Studio. However, after installing and then removing the framework through the Visual Studio Installer, I was able to reproduce the error you described. Installing the framework again allowed me to successfully generate project files for Visual Studio 2017.

If it is already selected, deselect it and click Modify to remove the framework and then select it and click Modify again to reinstall it.


vs2017.png (147.0 kB)
more ▼

answered Mar 27 '17 at 10:03 PM

avatar image agapesoft Mar 27 '17 at 10:08 PM

Thanks for your answers guys: I updated the VS installer and re-run it. I made sure I had the .NET framework, the windows 8 SKD, all the c++ add-ons and the Unreal support. It now runs at least the projectGenerator. I will now try and compile the engine and let you know.

avatar image Bioblaze Apr 04 '17 at 08:23 AM

Please let me know as well, i`m having the exacte same issues. XD would love to know how to fix it.

avatar image Tim C ♦♦ STAFF Apr 11 '17 at 07:07 PM

Hi Bioblaze,

If you run the Visual Studio installer and select the option to Modify your installation, what options do you have selected in the Workloads tab? In my case, I have the .NET desktop development, Desktop development with C++, and Game development with C++ options selected. For me, this seems to be all I need in order to use Visual Studio 2017 with 4.15.


avatar image Bioblaze Apr 27 '17 at 06:55 AM

i've installed vs2015, vs2017, every single .net Anything you can imagen, and yea Still cant get it to compile. Its also effecting me packaging plugins, and games as well. About too a point where i'll completely uninstall/reinstall windows 10. @.@

avatar image Tim C ♦♦ STAFF May 03 '17 at 06:12 PM

Could you please provide some screenshots from the Visual Studio installer so I can see exactly what components you have installed for VS 2017? Specifically, what options are checked in the Summary section for the .NET desktop development, Desktop development with C++, and Game development with C++ workloads?


avatar image Bioblaze May 03 '17 at 07:29 PM

I'm doing a complete Reinstall of Windows 10 pro edition within the Next Few days, For some reason, it I dont have 4.5 installed for anything. Well I do but it says I dont. I installed every single Option that is Available to install on both vs2015 and vs2017 I also had it working properly a few months ago. I believe it was the Windows Content CReators Update that broke this. So yea i'm doing a complete reinstall. I will tell you what happens after. :)

avatar image davidgfb Feb 05 '18 at 08:14 PM

It worked..

avatar image imskull Feb 02 '19 at 06:36 AM

In my case, I have to select ".NET Framework 4.6.1 Develop Tool" manually even I have installed ".NET Desktop Development" suit.

avatar image ManhHa95 May 22 '19 at 07:42 AM

thanks it worked for me after mannully selecting ".NET Framework 4.6.1 Develop Tool"

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

you need to check the "Unreal Engine Installer" box in the VS2017 installer. it'll check every required dependencies for VS2017 to work with UE4

more ▼

answered Mar 19 '17 at 08:51 PM

avatar image


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question